Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Exported images with transparency problem

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
Chtenelis
343 Views, 6 Replies

Exported images with transparency problem

I render my images with nothing in the background so I can put whatever I want afterwards in photoshop. I use depth of field so my model gets blurred. This blue background in the arnold renderview is just a color I choose in the arnold renderview settings. I put the same color in photoshop and this dark outline appears. I tried almost every image type.
Is there a way to fix this?

screenshot-2.png

Tags (1)
Labels (1)
6 REPLIES 6
Message 2 of 7
hyperviktor
in reply to: Chtenelis

Maybe try Nuke instead photoshop ?

Message 3 of 7
Chtenelis
in reply to: Chtenelis

I will try nuke in the future. Thanks for the answer!

Message 4 of 7
hyperviktor
in reply to: Chtenelis

You will definitely be able to sort this with a few clicks in Nuke, I have no clue how it would work in photoshop 🙂

Message 5 of 7
CiroCardoso3v
in reply to: Chtenelis

In Nuke you need to premultiply and in Photoshop the best option you have is to render the image with background as black so it doesn't show. Otherwise you will always have that edge. Which can also be removed in Photoshop using the menu Layer - Matting.

Lead Enviroment Artist @Axis Studios

Arnold Discord Server


Ciro Cardoso

EESignature

Message 6 of 7
Chtenelis
in reply to: Chtenelis

In nuke when i uncheck premultiply it improves a lot but still is not perfect.screenshot-1.png

Message 7 of 7
hyperviktor
in reply to: Chtenelis

Try using black in arnold BG instead of any color, if needed use a blue light instead of the BG for a subtle tint.


In nuke try using the unpremult node instead of the checkbox, you will have more options.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators