Community
Arnold for Maya Forum
Rendering with Arnold in Maya using the MtoA plug-in.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ASS render not using suffix (scenename.####.ass) but overwriting file every frame.

8 REPLIES 8
Reply
Message 1 of 9
Anonymous
1150 Views, 8 Replies

ASS render not using suffix (scenename.####.ass) but overwriting file every frame.

As I said in the subject/Question. I'm trying to render ass files for animation but the ass render is not using a suffix to increment the ass export. And is therefore exporting the ass file to the same location, overwriting it on every ass render.

I'm using Deadline to send renders to the farm. Via the Maya deadline submitter from within Maya.
In there I use the 'Arnold Export Job' along with the 'Submit Dependent Arnold Standalone Render Job' to get the ASS and the KICK render in one go.

I think the question really is what kind of Command Line argument do I have to add to the Arnold Export Job to make it render the ass files correctly.


(It does work by submitting the ASS and KICK render separately. The ASS from Maya without using the MayaBatch Plugin, and the KICK from Deadline). But I need the MayaBatch Plugin for xgen to work.

Here a screengrab of my exportsettings from the Maya Deadline Submitter.
2018-02-21-00-41-26.png

Regards,

Aron

Labels (4)
8 REPLIES 8
Message 2 of 9
ashley.handscomb.retallack
in reply to: Anonymous

In your maya scene render settings, what is the "Frame/Animation ext" set to?

It should be name.#.ext



Ashley Handscomb Retallack
Senior Software Engineer (Arnold)
Arnold Documentation | Arnold Downloads
Message 3 of 9
Anonymous
in reply to: Anonymous

It is set to name.#.ext
Like I said. It does work when I disable the Maya Batch Plugin.

I have a feeling that a Arnold Export Job assumes your rendering a still unless you tell it otherwise, but I haven't found any documentation that describes something like it.

Message 4 of 9
Anonymous
in reply to: Anonymous

try loading (browse) the maya file manually in Deadline render manager. Set render setting and the render path. Render only ass, not kick.

Chk its working or not

Message 5 of 9
Anonymous
in reply to: Anonymous

Like I said. It is working when I submit the ass and kick separately. (and not using the MayaBatch Plugin). But I want it to work with the MayaBatch Plugin so xgen works.

Message 6 of 9
Anonymous
in reply to: Anonymous

Anyone? I'm still stuck

Whenever I use the MayaBatch Plugin the ass that is being exported doesn't use padding.
Whenever I disable MayaBatch Plugin, xgen hair/fur doesn't render.

Message 7 of 9
Anonymous
in reply to: Anonymous

arnold-render-setting.jpg

please cross check this arnold render setting in your file.

Message 8 of 9
Anonymous
in reply to: Anonymous

No luck. That doesn't change anything.

Message 9 of 9
Stephen.Blair
in reply to: Anonymous

The Deadline Arnold Export Job worked fine for me. I didn't have to do anything special

You may want to take this question to a Deadline-specific forum.



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators