Community
Vault Forum
Welcome to Autodesk’s Vault Forums. Share your knowledge, ask questions, and explore popular Vault topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Windows 10 Fall Creators Update Breaks IIS on Vault ADMS Server

30 REPLIES 30
Reply
Message 1 of 31
Neil_Cross
1840 Views, 30 Replies

Windows 10 Fall Creators Update Breaks IIS on Vault ADMS Server

I had no idea this was a thing, have I missed an important official bulletin? Is there a critical warning area where this is logged because I can't find any reference to this pretty severe issue?

 

One of my colleagues received a very informal rushed mail shot from our local reseller about it yesterday, but I can't find any official warning about it.

 

You guys surely have to know about this now in the several weeks since Microsoft released an update to a supported OS, how come this isn't a sticky at the top of the forum at the very least? 

 

For anyone unsure if you have this issue.  If you go into IIS management area, Application Pools, you'll see the AutodeskFSPool and AutodeskDMPool are both stopped.  Logging into Vault Client will show the error 'cant find data management services' and opening ADMS, go to Tools > Administration will show the same error.

 

Windows 10 Fall Creators Update is still Windows 10 which is still a supported OS, anyone buying a new system now or creating a new media deployment using the Windows Media Creation Tool will be provided with this update without any choice in the matter. 

30 REPLIES 30
Message 2 of 31
ihayesjr
in reply to: Neil_Cross

Hi Neil,

 

Not everyone has the same issues with Windows Updates.  This is the first I have heard of this breaking IIS.  Do you have more than one instance of this breaking?




Irvin Hayes Jr
Sr. Product Manager
Autodesk, Inc.

Vault - Under the Hood Blog
Message 3 of 31
Neil_Cross
in reply to: ihayesjr

Capture.JPG

 

Indeed my Vault Server was installed on a Windows 10 box, I updated to the Fall Creators Update and it immediately knocked off Vault.  The two app pools are in a permanently stopped state now.  At the time I logged this thread, I found a few other people reporting the same issue on the Vault & Inventor forum but those posts had not been acknowledged.

 

 

 

Message 4 of 31
Neil_Cross
in reply to: Neil_Cross
Message 5 of 31
Neil_Cross
in reply to: Neil_Cross

And:

 

https://forums.autodesk.com/t5/inventor-forum/could-not-find-data-management-service-and-iis-is-not-...

 

But it looks like I missed this thread, there is a potential solution here.  But given all that, it's surely unlikely to be an isolated incident with the fall creators update.

Message 6 of 31
ihayesjr
in reply to: Neil_Cross

Thanks for the information Neil. Just as an FYI, Windows 10 is not supported for Vault Workgroup and Professional servers.

System Requirements




Irvin Hayes Jr
Sr. Product Manager
Autodesk, Inc.

Vault - Under the Hood Blog
Message 7 of 31
Neil_Cross
in reply to: Neil_Cross

And there's two more people at the bottom of this thread reporting the same issue with the fall creators update.  The other guy, robert, is the guy who then started another thread which was picked up and a solution offered.

 

https://forums.autodesk.com/t5/vault-forum/could-not-find-data-management-services-after-windows-10/...

Message 8 of 31
Neil_Cross
in reply to: ihayesjr


@ihayesjr wrote:

Thanks for the information Neil. Just as an FYI, Windows 10 is not supported for Vault Workgroup and Professional servers.

System Requirements


Yea I know, I'm 90% sure I read in the Cadline or CADPro article that this effects Vault Basic though as it's hitting IIS rather than the ADMS itself.

Message 9 of 31
DarrenP
in reply to: Neil_Cross

this also happened with the Anniversary & and the Spring Creators update and the fix was to run a reinstall on Vault server & this usually fixed the problem

DarrenP
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

Message 10 of 31
Neil_Cross
in reply to: DarrenP

Yea not this time for me, I tried repairing and reinstalling ADMS but the installer bombed out saying "IIS is not the default web server", the repair then cancelled.  I tried pretty much everything I could think of to get the ADMS repaired but it just wouldn't go through with it.

Message 11 of 31
cbenner
in reply to: Neil_Cross

@Neil_Cross

 

Could this be yet another .NET issue?

 

Can you go into you application pools on IIS and see what .NET is associated with the stopped pools?  Could be the update also changed your default .NET?

Message 12 of 31
ihayesjr
in reply to: cbenner

did you try the solution in this thread?

https://forums.autodesk.com/t5/vault-forum/could-not-find-data-management-service-on-server-and-iis-...

 




Irvin Hayes Jr
Sr. Product Manager
Autodesk, Inc.

Vault - Under the Hood Blog
Message 13 of 31
Neil_Cross
in reply to: ihayesjr

@cbenner all the app pools where on .NET4

 

@ihayesjr sorry no I didn't try that solution, it didn't appear in any of the search hits that I was finding at the time.  I've since rebuilt the machine which had the issue and will be putting ADMS onto it again tonight, a fresh build of the fall creators Windows 10.  Will be interesting to see if there's an issue putting ADMS onto it after the update rather than updating with ADMS already on.

Message 14 of 31
DarrenP
in reply to: Neil_Cross


Neil_Cross wrote:.  
Will be interesting to see if there's an issue putting ADMS onto it after the update rather than updating with ADMS already on.

yes this will be interesting if this works or not i actually have not tried this

DarrenP
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

Message 15 of 31
Neil_Cross
in reply to: DarrenP

Everything seems OK when you install ADMS 2018 onto a clean Win10 Fall Creators Update build.  Which would fall in line with the solution shown in the other thread.

Message 16 of 31
n.schotten
in reply to: ihayesjr

Well. i just encountered this same issue after a windows update.

I tried the deleting of the temp apppool, doesn't solve anything.

Message 17 of 31
n.schotten
in reply to: Neil_Cross

I had the same ISS issue this morning.

Deleting the apppool did nothing for me.
I had a 'AutodeskVault' user. i upgraded it's status to admin as per the other tread, and that seems to have brought back ISS/Vault.

So that was another hour of design/work time down the drain...

You always hear of how much (trucking) companies loose as a result of trafic jams...

How much (office) work is lost due to system mallfunctions and crashes due to update incompatibilities and just poor buggy programming...
This IIS/Vault crash would laydown a whole design team in small to medium companies that don't run Vault on a Windows Server system but on a regular W10 workstation.

 

Since installing/migrating to Inventor 2018 we have had so many crashes and bugs related losses that we have lost over 120 hours of work time between the 2 designers here.

Message 18 of 31
ihayesjr
in reply to: n.schotten

Although you found a solution that worked for you, maybe you can try the second solution found in this article then remove the AutodeskVault account from the Administrators group.

 

http://blogs.autodesk.com/vault/2017/12/windows-10-updates-breaks-vault-server/

 




Irvin Hayes Jr
Sr. Product Manager
Autodesk, Inc.

Vault - Under the Hood Blog
Message 19 of 31
n.schotten
in reply to: ihayesjr

Hi,

 

We didn't get a login failure. so asp.net was not the issue for us.
deleting the apppool also did not work.

setting the user permision to admin did work on our system.

Message 20 of 31
ihayesjr
in reply to: n.schotten

That could be only one way of seeing the same problem. By adding the AutodeskVault user account to the Administrators group, you gave it permission to something that it no longer had permission to because of the update. I would still recommend that you give this a try but keep the current solution if you like.




Irvin Hayes Jr
Sr. Product Manager
Autodesk, Inc.

Vault - Under the Hood Blog

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report