Revit MEP Forum
Welcome to Autodesk’s Revit MEP Forums. Share your knowledge, ask questions, and explore popular Revit MEP topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Revit 2022 Export gbXML not working

12 REPLIES 12
Reply
Message 1 of 13
sabdulameer
2817 Views, 12 Replies

Revit 2022 Export gbXML not working

I am trying to export the spaces to gbXML. when I first selected to export the files a window popped up with four selections I chose to export using Rooms/Spaces. I got and error message because there was no rooms in the project however there were spaces. After adding 2 rooms the gbXML file was generated directly without showing the option window in which you set the building type, check errors etc. Now the export is fixated on generating the gbXML file with only 2 rooms even if more rooms are added or all the rooms are deleted, the gbXML file will have only 2 rooms. is there a work around or an update to fix this issue? 

 

Thank you,

 

Tags (1)
12 REPLIES 12
Message 2 of 13
iainsavage
in reply to: sabdulameer

You could try deleting the Energy Model and re-creating it before exporting. Not sure though if that will help.

I presume you’ve read the help page, and have you filled the whole volume of the model with room/spaces including shafts, chases, ceiling voids, roof voids etc? Are you exporting from a 3D view as it says?

https://knowledge.autodesk.com/support/revit/learn-explore/caas/CloudHelp/cloudhelp/2021/ENU/Revit-D...

Message 3 of 13
sabdulameer
in reply to: iainsavage

I have deleted the energy model, but still have the same issue. Yes there are spaces that fills all the voids  and I am exporting in 3D view. I am using the same method that I use in Revit (2019, 2020, and 2021). Not sure what is happening with 2022, when I click export gbXML it exports the file directly without showing the Export gbXML-Setting window.

Thank you,

Message 4 of 13
iainsavage
in reply to: sabdulameer

I've tried the export and it seems to work okay for me. Tried adding extra rooms using separation lines and the exported xml file seems to have the correct number of spaces each time.

The dialogue box also appears each time.

I'm not trying to insult your knowledge but I presume that you didn't tick the "Do not show this message again" box?

iainsavage_0-1639692601787.png

 

Message 5 of 13
paveen_roj
in reply to: sabdulameer

I'm also having the same problem.

Have you figure out how to fix it?

 

This can be troublesome.

Message 6 of 13

The same problem.

Still no solution?

Message 7 of 13
1401452
in reply to: sabdulameer

Same problem hope there is a solution for it
Message 8 of 13
dwessels4R92P
in reply to: sabdulameer

You probably miss using the gbXML export preview UI from previous versions of Revit to help check for errors before exporting the gbXML file. In Revit 2022 they removed the gbXML export preview UI as an enhancement. I haven't tried the new analysis mode in Revit 2022 yet to determine if it has the same functionality to check for errors before exporting to gbXML. There is a brief blog that covers the new analysis mode in Revit 2022 with some additional links https://blogs.autodesk.com/revit/2021/04/15/whats-new-for-mep-in-revit-2022/

 

Removed the Export gbXML preview UI and added the new analysis mode "Use Rooms or Spaces" in Energy Settings.

Message 9 of 13
sanjivY3P8E
in reply to: sabdulameer

I'm facing the same issue. The export gets fixated on the model state when we exported for the first time. Any subsequent exports simply ignore the edits we made to the model. Hope we have a solution..?

Message 10 of 13
iainsavage
in reply to: sanjivY3P8E

Re this statement in the original post "After adding 2 rooms the gbXML file was generated directly without showing the option window in which you set the building type", I suspect that the Do Not Show This Message Again button was checked.

iainsavage_1-1670842492180.png

 

If that's the case then open the Revit.ini file (the version in C:\Users\USERNAME\AppData\Roaming\Autodesk\Revit\Autodesk Revit 20xx) and delete these lines below, save the ini file. Close and reopen Revit and the dialogue should reappear next time you export to gbxml.

iainsavage_0-1670842451435.png

 

Message 11 of 13
ssoboloski
in reply to: sabdulameer

It appears that Autodesk completely revamped the Export gbXML "preview" between the 2021 and 2022 releases. See below for my recommended steps to view the analytical surfaces. I believe this workflow addresses various questions throughout this thread.

 

  • Export file to gbXML for use in load or energy calculations. To export to gbXML follow the steps below.
    • Create a Space Schedule and confirm there are no "unplaced" or "unenclosed" spaces.
      • There should also be no enclosed area within the zone map without a space assigned. Chases/shafts should be absorbed by adjacent spaces or assigned a unique space tag.
    • On the "Analyze" tab, within the "Energy Optimization" panel, select "Energy Settings".
      • Under "Energy Analytical Model", for "Mode", select "Use Rooms or Spaces".
      • Under "Advanced", select "Other Options", scroll down to "Room/Space Data" section, and set "Export Category" to "Spaces".
    • Within the "Energy Optimization" panel, select "Create Energy Model".
      • Select "Create the Energy Analytical Model" in the window that pops up.
    • Open "Visibility/Graphics Overrides", navigate to the "Analytical Model Categories" tab, check the box for "Analytical Surfaces", and select "Apply".
    • In the "Properties" window, under the "Graphics" section:
      • Set discipline to "Architectural" or "Coordination".
      • Select "Graphic Display Options" and set "Style" to "Consistent Colors" or "Shaded".
    • To display any subsequent changes to the zone map, delete and recreate the "Energy Model" from the "Energy Optimization" panel.
    • Click "File", below the "R" in the top left corner.
    • Select "Export", then select "gbXML".
    • Confirm all modeled architecture is accounted for (walls and windows will be shaded green if they are included in the calculation). If not, your spaces may not be modeled correctly.
    • Select "Use Rooms/Spaces Elements", navigate to the location you wish to save, name your file, and click "Save"
Message 12 of 13

Thanks you, this worked perfectly when Importing / Exporting to Relux out of Revit 2022.

Message 13 of 13

It worked for me, thanks!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Forma Design Contest


Technology Administrators