Welcome to the Revit Ideas Board! Before posting, please read the helpful tips here. Thank you for your Ideas!
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Disable Auto-Join Option

Disable Auto-Join Option

Often times Revit's burning desire to auto-join beams, columns, walls, etc. hurts more than it helps.  There are many instances of complex joinery, or the overlapping of certain elements, or basic modeling work-arounds, where I know exactly how to draw something but the auto-join keeps messing it up.  It feels a bit like Microsoft's old Office Assistant "Clippy" which tried to help but was just annoying in the end. 


All I want is a mode in Revit in which I can draw anything I want, as precisely and accurately as any other CAD platform, just like AutoCAD, Inventor, Rhino, SolidWorks, etc. etc., without interruption or worry about it changing unexpectedly in the future.  Pinning/locking is not good enough.  To be clear, snapping is a different behavior which deserves its own on/off toggle.  The auto-join processor is the real pain.  There has to also be some type of performance boost by turning all this logic off too.


This is most often the case when it is late in the design process, after drawings have been issued a few times.  Please stop making me paranoid that the model will update and adjust people's hard work.


Something that has annoyed more users then benefit since the release revit: Automatic joining of beams like magnets when they get to close to each other.

See example below, that is common practice in construction. Always have to use tricks to disallow them to join like magnets....

So please make it an Option for the user, instead of default magnetic beam behavior! 




I raised this as a support query and also on the architecture forum, where I learned a few more wrinkles to the problem.


Columns automatically join to beams when they are placed in close proximity to the beam. If you create a column below a beam junction (eg a mitred joint) the beam join will be broken as the column join takes precedence. There does not seem to be any way to restore the beam/beam join. The join tool no longer recognises the beams as join candidates and there is no way to tell the column not to join.


Note: this is usually only a problem if the beams have bottom z-justification. If the beams have top z-justification it is possible to place the column or attach it to the beams without triggering the automatic join.


There are a number of ideas in this forum that recommend changes to the way automatic joins work, and I am sure there is merit in them, but I would be happy with a simple mechanism to suppress column joins. We can tell the end of a beam or a wall not to automatically join but we can't do this with a column.


The solution could be as simple as adding checkboxes to the column properties which would control join behaviour at top and bottom of the column. The option would be checked by default to allow automatic joins but you could uncheck it to suppress this behaviour.

Tags (4)

I am working on a high rise building of over 180 meters tall and I depend largely on the revit material quantity take-off. In regards to beams, specifically concrete beams, I've notice that they automatically joins by their axis and there is no way to disjoining them, which gives me an erroneous data of length and even cut length. I respectfully suggest, to give at least the option to not join them automatically and also avoid to automatically extensions the beam so I can get a more clean model as well a more accurate data for the material take-off.


Best regards,


Maria Patricia Franco

BIM Director

Tags (3)

Have you tried to use Precast Concrete or Unjoin Geometry command?

The beams are in precast concrete and I have used unjoin geometry but the
beams always use the automatic extend which is affecting both the length
and cut length.

Still, thank you for your answer. 😃

I doubt that this request will be accepted. If you right-click on the end of the beam, you can Disallow Join. Then copy this beam. If this is not suitable, then make a beam based on the generic model family template.


It might be better to create a new idea like "Change Join Status for a structural framing before creating" - this would be a nice feature.


I wish they would make this so. It makes no sense that its such a HATED feature and they persist on forcing it on us anyways, as if we wont just use a different program and leave theirs completely. 


So good ol' autodesk. here we are many years later and still no way to globally disable auto beam joining. I am repeatedly having to move beams because of this retarded inbuilt feature. Costing my time and my employers time.


Yeah, seriously! This auto-join business has been way more trouble than it's worth, in almost all cases. I especially hate how it is difficult to stack wall types. 


3 years later also here still looking voor a solution for auto joining wich indeeds sometimes create more problems than it solves


Yup, seems like a regular past time to find the issue you are looking for in the forums, dated from years ago, with no solution to the issue. Guess that is what happens when a company has a pseudo-monopoly and no interest in making a better product.


The join behaviour is unpredictable and causes a lot of frustration and errors for what should be a straightforward action (basically defining the length, start- and endpoints and XYZ-location of a profile-based Sweep).



  •  Making it easier to disallow join on multiple elements (already possible with the API but should be native)
  • Making the join status of each end visible and editable within Properties (and Schedules)
  • Offering the possibility of having disallow join be the default behaviour for new Structural Framing.
    • If you are reluctant to change default behaviours, give us the option to disable it. If you feel it clutters up the UI, offer us the possibility to disable it in Revit.ini.

These relatively minor changes would improve the usage experience and productivity by leaps and bounds.


This "feature" is infuriating. Trying to chase the erratic behavior of the software, which keeps changing the lengths of beams when building near them, or changing other things around them, in inconsistent ways, has led me to create constraints to try to keep beams in place, which has created an over-constrained model that is now totally f'd. 


The process, as noted above, defining XYZ coordinates of a sweep, should not be complicated. And the default behavior of software should be as expected. What happens now, where Revit automatically changes beam lengths after they are placed due to the creation of new or modification of existing items, is neither simple nor expected. 


Thankfully, the "disallow join" button is available (see below) but I am confused why this is not the default behavior. It requires relatively new users (3+ years) days of headache and frustration to realize the thing they have been fighting all along is not user error (at least initially) but rather a supposedly useful feature of the software ... that is anything but.


If you found this thread after beating your head against your keyboard, I feel you!


Update: I have been able to make the software work as expected. I had to rebuild the model, to get rid of ghost / legacy constraints, improperly hosted / grouped / referenced items, whatever was causing the erratic behavior.


When rebuilding the model, I carefully selected "disallow join" on every element that I put in place. If you are new to this problem, this option is available (at least on Revit LT 2022, but I'm not sure when it was introduced) in the drop-down menu upon secondary click on the blue dot that allows you to drag the length of structural members. See screenshot below. This dot will not be visible if you have the element pinned. The process involves a tedious number of extra mouse clicks but is totally worth it to avoid erratic behavior down the line. IMHO.


(The other thing I have learned is it is possible to have auto-locking turned on for the align command. At some point this got toggled, and I was creating restraints I was unaware of. So beware of this.)













I work for a pre-engineered wood supplier, where product has a 1/4" tolerance for proper fit of trusses.  The auto-join function totally messes up the actual length of products that are being supplied, so I have to remember to unjoin every stick.  I see when creating a wall,  they now have a toggle to turn off allowing joins. It would be great if they could use similar coding to make that an option on anything input as a "beam".



Please make this feature that beams dont joined to wall automatically

Espetially when joined point of beam is "Dissalow"

Because write now even if point is "Disallow" - beam anywhere trying to connect to top or bottom of wall




Those of us who use Revit to create structural framing (timber framing) drawings are constantly facing issues with the default auto-join feature of beams in Revit - please can we have a setting to turn beam joins off as a default?


See this help thread for details of the issue:


The nightmare of auto-joins is not solely with structural framing. Also, structural foundations cut piles, and as mentioned above, wood structures with tolerances are almost impossible to handle in large-scale projects.


Most of the time will be wasted to correct Revit's "handy" auto-join chaos instead of doing some actual design work. 

Can't find what you're looking for? Ask the community or share your knowledge.

Submit Idea  

Autodesk Design & Make Report

Autodesk Design & Make Report