Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

You cannot save the link…because it has changes in more than just shared coordin

11 REPLIES 11
SOLVED
Reply
Message 1 of 12
ThierryMonteyneSWECO
5726 Views, 11 Replies

You cannot save the link…because it has changes in more than just shared coordin

@ryan.duell

Created a separate topic just for this issue:

image001.jpg

You wrote:

We have seen a few reports of this message related to certain model elements (in the link) that interfere with the normal checkout of the project info workset; Revit is unable to make the necessary change and this message is displayed.

 One thing we can do to get a better idea of what type of element(s) is causing this message:

 1) After you receive the “You cannot save the link…because it has changes in more than just shared coordinates…” message and click ‘Close’ on it, navigate to the Revit journal files location.  For example, for Revit 2018 it would be:

 C:\Users\%username%\AppData\Local\Autodesk\Revit\Autodesk Revit 2018\Journals

 2) Open the current Revit journal file for the active session (should be the most recent journal in the folder); there is some additional diagnostic information captured in the journal.  Search for the following:

 cantSaveSourceBecauseItIsCentralWithTooManyChanges

 3) There should be at least one line in the journal reporting this.  Generally you will see three “Change ids” which are element ID’s in the Revit link.  The first two numbers are generally the location data element and the shared site element.  The third number is usually one of the problematic elements; that is the most important.  Copy that number.

 4) Open the Revit link that is triggering the message and do a Manage > Select by ID.  Paste in the number and click OK.

 Can you let us know what category the element is?

 If you are seeing this with a specific Revit link and have not already done so, I would recommend creating a support request so we can assist debugging the issue.

 

 

A simple project, the aspect model, from our company template with 1 actual object, linked in a coordination model, the master model. And did get the error, saw this in the journal:

 

' 3:< DBG_WARN: cantSaveSourceBecauseItIsCentralWithTooManyChanges should never return true (SPR 108802). Changed ids are:  9835 9836 236403: line 432 of RvtLink\RvtLinkUI.cpp. 

 

ID 236403 is a 3D View.

Deleting the 3D View has no effect, because the next time we try the journal throws another 3D View.

Deleting all 3D Views has no effect.

 

Starting an aspect model from scratch (metric template) does not render this problem.

Either I have to rebuild our template over again, or I hope you have an idea?

 

Regards,

Thierry

11 REPLIES 11
Message 2 of 12

Hi @ThierryMonteyneSWECO,

 

Here's an update based on our recent communication.

As the next step, a problem report has been filed for your support Case: 14342033 

 

Thanks for the detailed information and for uploading your files. I will let you know if we require additional information from your end.

 

I have shared your files with the dedicated resource team to further investigate your issue.

Please look forward to updates with further developments in terms of finding a solution.

 

Regards,

 

Message 3 of 12
Viveka_CD
in reply to: Viveka_CD

Hi @ThierryMonteyneSWECO

 

Thank you for your patience.Smiley Happy

 

Your issue is in progress and the files are under investigation.

I'm trying to reproduce the steps shared by the development team, please expect an update tomorrow. 

 

Regards,

 

Message 4 of 12
Viveka_CD
in reply to: Viveka_CD

Hi @ThierryMonteyneSWECO

 

I've emailed you the screencast and steps through Case #: 14342033

Please let me know if this helps and let me know if you have any questions!

 

I look forward to hearing from you.

 

Regards,

 

Message 5 of 12


@ThierryMonteyneSWECO wrote:

 

Hi Viveka Thank you for the time spent on the issue. I deleted the elements with the ID's provided, generated a new template and created a new project with worksharing from that template. It works as expected. But is there a way of preventing the corruption? Again, thank you very much. Regards, Thierry Monteyne

 

(I've quoted your private message above to close the loop)

 

Hi @ThierryMonteyneSWECO

 

I'm glad to hear that the recommended steps from the development team helped resolve your issue.

Thanks, @ryan.duell for prioritizing this issue.

 

For best practices and recommendations to prevent model corruption:

Let me know if this helps, and if you have any concerns or questions I am happy to find some more information for you.

 

Regards,

 

Tags (1)
Message 6 of 12

This problem appears in Revit 2017 alot

#Solution is:

1.Unload all CAD Links from the linked Models.

2.Unload all Revit Links from the linked Models.

3.Relinquish and save, then reload it again in the host file.

4.Now publishing procedure will go smoothly.

______Some rare times if problem still exists you will need to unload the host links as well.

 

##Option 2

1.Try closing all worksets of the linked file.

 

Regards,

Alaa Elkabbany

Architect - Bim Specialist
Dar Al-Handasah (Shair and Partners)

Message 7 of 12
Anonymous
in reply to: Viveka_CD

Hello, I have having the same issue on one of my models when trying to publish coordinates. The problem element happens to be a plan view and I do not know how to fix this issue. I have made sure everyone has fully synchronized and relinquished and even detached from central to attempt fixing this issue. This is a view that I need and am unable to discover why it would be causing issues. Thanks for any help you can provide.

Message 8 of 12
ThierryMonteyneSWECO
in reply to: Anonymous

Hi Josh

 

The issue was my template was faulty. Autodesk identified the problem, and send me a walkthrough how to fix it. The bottom line I had to select multiple element by the Revit ID's they gave me and delete them all at once. The result was devastating: most of the Views were deleted. I started building up my template again and currently my new projects do not have this issue anymore.

 

However with projects already started, you cannot simply remove all your Views. You just can't get away with it explaining your boss "there was an error in the model." And this is your current situation. There a two options you can do:

The first is using the acquire coordinates method. Tricky part is when the survey gets is relocated (for what ever reason it may be), a secundary acquire will generate a dialog "this model has already the same coordinates system". Just remember, a coordinates system in Revit also has an ID. Knowing this: insert a complete new model with "something" in 3D (just to select it), acquire the coordinates system from that link (destroying the Revit ID of the coordinates system currently present), save your model. Remove that temporay link and re-acquire the proper coordinates system from the file you want.

The second is actually bypassing the fault: make sure your model is not a central file when you publish the coordinates. After the save re-introduce worksharing again. Downside: if you use custom worksets they will be destroyed.

 

Also think on the following: in a BIM360 environment publishing coordinates is not available due to rights. Acquire is the only method in this case.

 

Hope this helps for your current project.

And do check your template, maybe it needs attention too.

 

Regards,

Thierry

 

 

Message 9 of 12
stevie_kelly
in reply to: Viveka_CD

Could you please share that link? I'm glad your problem was solved, but I have the same problem and would love to know how you fixed it.

Message 10 of 12
Viveka_CD
in reply to: stevie_kelly

Hi @stevie_kelly 

 

Are you referring to the article link?

 

Please check AKN article link:

Error: "You cannot save the link because it has changes in more than just shared coordinates" in Revit

 

Let me know if that helps!

 

Regards,

 

Message 11 of 12

Thank You. This solved my problem. I did not have the same issue as the OP but i did have the same error. Much obliged.

Message 12 of 12

@Viveka_CD 

Morning,

According to the threads and articles referenced here this issue was resolved in a 2019 update, but I am getting this error in a 2022 model this morning. 

 

I will start investigations into the journal files and attempt some of the solutions provided above in the meanwhile, but thought it should be reported that it's popping up in later versions again. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report