Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Revit Crashing When Modifying 2D Grid Extents

14 REPLIES 14
Reply
Message 1 of 15
Daniel.Carey94
1343 Views, 14 Replies

Revit Crashing When Modifying 2D Grid Extents

Hello,

 

 The challenge my team and I are experiencing revolves around 2D grid extents. We have created a series of enlarged floor plan drawings. When these views are first created, any grid line which passes through them is cropped to an arbitrary offset outside the annotation crop region. Any time we try modify the 2D extents of a grid line in these enlarged plans (1:50) in specifically one of our models, Revit crashes. 

 

Any thoughts as to why this is happening?

 

For some background context, we are using BIM360, Revit 2019, and have 12 separate models that are cross-linked into each other. I'm working on a joint venture project where the Revit model was set up by a different architecture firm. The model that keeps crashing is excessive in size - 500MB. Even still, we have 128GB of RAM, 2.5 GHz processor, and a NVIDIA Quadro P4000 video card - none of which max out while this error is occurring. 

 

The workarounds we are currently utilizing are:

 

1. If you change the crop extents of the view so that the grid line is no longer within its extents and then extend it so that it is, the grid line will shrink, but by an inapproximate length.

 

2. If you right-click the grid line, and select "reset to crop region" the grid line extents will move with the crop extents. This, however, does not work as the extents of these enlarged plans are positioned around the area of interest and doesn't have the flexibility to shrink any more. 

 

3. If you turn off all worksets except the grid line and then modify the 2D extents, the Revit model still crashes. 

 

Any other suggestions would be greatly appreciated.

14 REPLIES 14
Message 2 of 15

@Daniel.Carey94 

 

I am sorry you are experiencing crashes while working in this project. 

 

To help find a solution, are you able to reproduce the crash and provide a journal file? Is there a error message that pops up when Revit crashes?

 

When Revit crashes, does it present a chance to send in a crash report? If it does please enter an email and sent it in, a web page should pop up with report number as well. 

 

Message 3 of 15

Hi Eric,

 

I've attached the journal file that I believe is associated. There is no error message pops up. The file freezes (for for hours, we've tested) and end up having to force quit. At a loss for possible fixes so any help would be greatly appreciated!

Message 4 of 15

Hi Daniel,

Please attach the journal file for the associated transaction. Journal files are TXT files (look for Journal.*.txt). The log you included is for a background process that's shouldn't block the main process in way you indicate.

Thanks,

Sasha

Sasha Crotty
Director, AEC Design Data

Message 5 of 15

Hi Sasha,

 

Sorry. Hope this is the right file.

Message 6 of 15

@Daniel.Carey94 

 

This journal file was from this morning, did you experience the same behavior? 

 

I am seeing a lot of collaboration cache issue, I will see about that with my colleagues. 

Message 7 of 15

Hi Eric,

 

Yes, I was experimenting with it some more this morning. Tried using scope boxes but that crops the 3D datum extents not the 2D extents, as desired. There are about 20 uses who work in the models in two offices in two different continents, so lots of collaborators/data.

Message 8 of 15

@Daniel.Carey94 

 

I have private message you for a model a workflow video. I hope to hear from you soon.

Message 9 of 15

Here's that journal file.

Message 10 of 15
oskyparkin
in reply to: Daniel.Carey94

Hello,

 

I would like if you found a solution for this issue. I am experiencing the same issue with Revit crashing (the model freezes) when we are editing the 2D grids, thanks a lot,

 

Oscar

Message 11 of 15
rwooten
in reply to: oskyparkin

My Team is also experiencing this issue. Any updates? 

Message 12 of 15
emodderman
in reply to: eric.zhang305

I've got a client file with these issues right now. File is only 52mb, so not huge, but the 2D or 3D Level extents cannot be changed at all without Revit running into a tailspin of reprocessing the extents. Currently, there are no scope boxes in use for these extents, but it was an option we were going to try. However it seems from earlier posts that this will not solve the problem.

 

Did anyone ever get any answers to this?

 

We're using Revit 2019 on this file, but I've tried Revit 2020 and nothing changed. I will be trying 2021 shortly. 

Message 13 of 15
rwooten
in reply to: emodderman

For our file, which is pushing 1GB, so much larger, it turns out a number of team members were constraining elements that didn't need to be constrained such as detail items and filled regions that were being copied and pasted through the set, resulting in thousands of constraints. I turned on the show constraints view selected a constrained dimension and deleted all in project. This freed up the grids and levels. I then had to go constrain elements that actually required it. Not sure this solution applies to your situation, but it's what worked for us. Good luck!

Message 14 of 15

Did you find a solution?

Have same issue

Message 15 of 15

@Daniel.Carey94  

My team and I have the same problem with our projects. Did you find a solution?

We use Revit 2021

This article says that the problem is solved in Revit 2022 but not in other versions of Revit

https://knowledge.autodesk.com/support/revit/troubleshooting/caas/sfdcarticles/sfdcarticles/Slow-per...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report