Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Revit 2016 to 2017 text problems

15 REPLIES 15
Reply
Message 1 of 16
BrandoniousMaximus
1653 Views, 15 Replies

Revit 2016 to 2017 text problems

I am not new to this site but have never made a post. I been a Revit user since 2006.  Mostly structure.  

 

The new font options are pretty cool in the new 2017 version.  

 

I noticed that when I upgraded an existing model from 2016 to 2017, all of the font changed size and parameter.  

 

Even though the information in the Type Properties box is the same, the text size is different.  

 

Here is an example:

 

2016

Revit 2016.PNG 

 

And then in 2017

Revit 2017.PNG

 

 

and just to further show what the type properties are

Type Properties.PNG

 

 

 

 

Any advice?

15 REPLIES 15
Message 2 of 16

Is both models using the same font? it seems to be the font that's causing the issue. Try reinstalling the font.



If this information was helpful, please consider using the Accept Solution


Message 3 of 16

Hi Darin, I tried reinstalling it in windows but it doesn't appear to change anything.  Good idea though.  I am still using 2016 and it seems unaffected.  Strange.  

Message 4 of 16

I just tested it. There's an issue with the "Calibri Light" font. change it to Arial and try again.



If this information was helpful, please consider using the Accept Solution


Message 5 of 16
Ruach
in reply to: BrandoniousMaximus

I discovered some weird bug in the new text editor. After upgrading the project from 2016. When I create new text within a viewport that’s on a sheet. The text selector stays on the left while typing – making it impossible to select text and edit/erase. when i move my type selector with my keyboard arrows, the left arrow moves the selector to the right and the right arrow moves it to the left, BUT! when typing the actual typing doesn’t start where the selector is, instead it follows the real directions of my keyboard arrows – making it impossible to know where you are editing/typing.

_____________________________________________________________________________________

Feel free to donate a Kudo. Remember if a comment helps you to your problem, please accept as solution.

Happy Reviting!
Message 6 of 16
BrandoniousMaximus
in reply to: Ruach

Totally frustrating.  

 

Our Arcitect put Revit17 on hold untill it gets ironed out.  

 

We have spent years perfecting our detail library and titleblocks and this would be too much of a setback.

 

Glad I am not going crazy 🙂

Message 7 of 16
Ruach
in reply to: BrandoniousMaximus

Apparently support is working on a fix for what I just mentioned (mirroring issue) 

_____________________________________________________________________________________

Feel free to donate a Kudo. Remember if a comment helps you to your problem, please accept as solution.

Happy Reviting!
Message 8 of 16
hidlayarchitecture
in reply to: Ruach

It seems that if you take away the arrow on a text block, while editing, then add the arrow back it will work somewhat normally. The cursor is still hard to follow or doesn't blink consistently. 

Message 9 of 16

Nevermind, that doesn't seem to be consistent. Sometimes adjusting the size of the text box works. This is unbelievable! Who was doing the beta testing? Why was this released as such?!!!

Message 10 of 16

And...What's with the esc key prompting a dialog box? I realize how frustrating it can be to accidentally hit escape and lose what you just wrote but the text in boxes typically aren't bigger than a small paragraph.  Would be nice to turn this feature on/off. 

Message 11 of 16

As I'm spending more time having to deal with this issue (upgraded a project then did days worth of modeling before annotating and realizing what a disaster this is) I'm noticing something. The problem seems to be primarily with cursor visibility. This is also evident when editing text anywhere in the program so it's a graphics problem?  I tried disabling hardware acceleration with no luck and beyond that don't really know what other options to try.

 

So this could be described best as the ghost cursor glitch?

Message 12 of 16

I havent noticed any missing (ghost)cursors just yet.  I can get the strange width problem worked out if I change the Width Factor to .90 from 1.0 but that is a sloppy work around that has not needed to occur in previous upgrades.  Frustrating.

Message 13 of 16

Update the graphics card driver and you're mouse driver to the latest version.



If this information was helpful, please consider using the Accept Solution


Message 14 of 16

I have a fairly recent graphics driver with a new geforce Nvidia card, but have had serious issues with the latest driver un related to Revit. My mouse is up to date. Thank you for the suggestions.
Message 15 of 16
brandonl
in reply to: Darin.Green

Updated the graphics card, no dice.  

Message 16 of 16

*UPDATE*

 

My software destributer is telling me to do  what I already figured out.  I changed the "Width Factor" in the Text "Type Properties" box to 0.90 (or in some cases 0.80)  This is a weak fix(I dont like work arounds) but a fix none the less untill they fix the spacing issue.    

 

I was glad to hear that I wasnt the only one with this issue.  They have a growing list of companies that have the same problem.  

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report