Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Errpr - Cannot open file, File has become corrupt - Contact support for recover

2 REPLIES 2
Reply
Message 1 of 3
dtpeter2901
267 Views, 2 Replies

Errpr - Cannot open file, File has become corrupt - Contact support for recover

The cloud shared file isn't corrupt, but this happened today.

 

Using C4R on a project we ran across this error today.

 

I had a user that tried to open a file by navigating to the C4R cloud site and selecting it and is started to open and they were prompted with the error that "The file has become corrupt and Revit  can't open the file, contact support".  Knowing that the file on the cloud isn't corrupt (Since I was able to open it fine on my workstation) we tried the first recommended work around.  Go to the users' collaborationcache folder and delete the folder.  

 

The method we've used is to close revit and the communicator, and go to the cache folder and delete everything.  In theory one would think this should remove all remnants of the local file and force a full download from the cloud.  But when we tried again we got the same error.  So we closed Revit, went back and deleted the cache folder again and decided to restart the computer just in case.  Still no luck.  

 

So we went to Workaround option #3 - Open the file on another computer that you've never opened the project on.  Wait for the file to open (It opened just fine) and the save it back and close revit.  Go to the collaborationcache folder and copy it back to the users typical workstation.  We did this and it worked.  So yes the workaround solved our problem.

 

My question is what causes the need to go through the extra step of having to open it on another workstation and then move it?  If I delete all of the local files, whats still being stored and where, that's not allowing this issue to resolve itself.  This just seems like a odd issue.  I'm more interested in what's going on since the work around works, my question is why.

 

Any insight

Thanks in advance.

2 REPLIES 2
Message 2 of 3

Hi,

Based on your description on how it behaved, I'm guessing that one of the cached files in the Revit Personal Accelerator cache (aka PAC cache) is/was damaged (This cache is located in C:\Users\[WindowsUser]\AppData\Local\Autodesk\Revit\PacCache).

 

See step 5 in the following kb on how ti identify and delete a model from the local cache:

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/sfdcarticles/sfdcarticles...

 

 

Regard

 


Lars-Ake Johansson
Sr. SQA Engineer
Message 3 of 3

So Dave and I are working on this issue together and we have cleared our caches locally and rolled back the model and are still having this issue after rolling back and removing the local cache each time for 4 consecutive times.  Any other thoughts before we keep going back?  I have even tried to recover one of those local files from a user in the Collaboration Cache folder and no luck, still says its corrupt.  I find it odd that people were working in the file until 8pm and yet recovered files from 5 are still saying they are corrupt.

 

-Eric

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report