Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4R: Can't edit the element. It was deleted in the Central

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
hjinirio
16090 Views, 10 Replies

C4R: Can't edit the element. It was deleted in the Central

We have a fitting that isn't allowing us to delete it. the error that we are receiving is the " Can't edit the element. It was deleted in the Central". The workaround that we are doing is creating a detached copy, renaming the file on the A360 directory and deleting the old one from the directory. I would like to know if there are any other suggested solutions. Thanks

10 REPLIES 10
Message 2 of 11

Hello Hector,

 

My name is Riccardo. I am a Revit specialist.

 

 

So far the best workaround to overcome this issue is what you mentioned in the case: 

 

Opening the file with Detach from Central and Audit checked, then Preserve Worksets. After the file opens save it as a new Central overriding the existing.


Please let me know if this helps you to resolve the issue

 

If I do not hear from you within 2 business days, I will archive the case. Despite of it, if you have any additional questions or concerns you can still post them here.

 

Best regards,

 

Riccardo Evangelista
Autodesk Support Team






Riccardo Evangelista
Autodesk Revit Technical Support
Message 3 of 11

Hello. I am having a similar problem as outlined above, only his solution is really not feasible (at least, in my opinion) for our project. 

 

There is a single pipe tee that the program claims has already been deleted in the central file. We are working in C4R, one of six different consultants working in this project, and I am the only one who has been in our "MECH" model. There is no "editted by" field in the properties, or any other indication of where I can go to edit/relinquish the element. 

 

If I understood your solution correctly, I do not believe this would be a good fit, as there are multiple firms that would have to re-link our model back in. Of course, I could be mistaken in my line of thought here - (this is our very first C4R project, and I am not exactly BIM extraordinaire yet). What I plan to do, at least temporarily, is simply hide the fitting and work around it. 

 

Thanks in advance for anyone's time in reading/replying to this!

Message 4 of 11
beziojs
in reply to: HA_Team_02

an option is to save as but not change the name of the file.  this would fix the problem and also keep your consultants from having to re-link

Message 5 of 11
JeffSkipper
in reply to: HA_Team_02

Hey just posting a solution which worked for me after an hour of failures:

 

Make sure you are the only one on the project, then take ownership of all worksets. Do a synchronize, and hopefully it will solve the problem like it just did for me.

 

Good luck!

 

edit: Problem came back after relinquishing. When you have ownership of all worksets, you may need to nudge the broken elements over and back. Anything to edit them slightly. I swapped their workset to something different, and back again. Its all working nicely now.

Message 6 of 11

That worked! Thank you.

Message 7 of 11
d.kenyon
in reply to: hjinirio

To resolve this problem try auditing your Revit model. 

Dave

Message 8 of 11
aftab_Sid
in reply to: JeffSkipper

Awsome work , that worked perfectly for me 

Message 9 of 11
khosseini
in reply to: JeffSkipper

Thanks,
It works.
Message 10 of 11

i thanks alot i found your sulution is very helpfull.
thnks again

Message 11 of 11

Open file with "Audit" option. Only using that way I was able to fix elements.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report