Revit Cloud Worksharing Forum
Welcome to Autodesk’s Revit Cloud Worksharing Forums. Share your knowledge, ask questions, and explore popular Revit Cloud Worksharing topics.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

C4R 2017 clean install?

Message 1 of 3
599 Views, 2 Replies

C4R 2017 clean install?

How does one completely remove and re-install C4R for 2017?


Today the Autodesk Desktop App showed me two new updates for C4R, one entitled "Revit 2017 A360 Collaboration v2 Fixes", the other "Revit 2017 Personal Accelerator v2 Fixes". Both updates failed with the message that "a previous version is already installed" which is a baffling error in the first place. Of course previous versions are installed, I'm trying to install an *update*.


I tried to remove both C4R and Personal Accelerator via the Windows Add/Remove Programs control panel. C4R uninstalled smoothly but Personal Accelerator would not.


I then downloaded the C4R v2 standalone installer from, and it too would fail.


Now I have both of the original updates showing up in the Desktop App, along with "Autodesk A360 Collaboration v1 for Revit 2017".


This is beyond frustrating. How do I get out of this mess? Do I need to completely nuke Revit 2017 and reinstall from scratch?



Message 2 of 3


No, you don't have to reinstall from scratch.


As you noticed, there where some issues with the update and we are sorry for that.


We have disabled the update and will hopefully re-post in the beginning of next week (Aug 8). This is probably also the reason you see the original v1 version in the app.....


There was a failure in how the installer identified earlier installed version that lead to that it didn't get uninstalled before we tried to install it again. This also lead to that it appeared again in the even if it was installed.


And yes, the same problem is it the standalone installer as well, you should however be able to 'update' by uninstalling the previous version of Collaboration for Revit and Personal Accelerator.


As for uninstalling PAC:

- What is the error you get when you try to uninstall?

- Do you have other versions of Revit/C4R installed on this system as well?


We are sorry for the inconvenience.




Lars-Ake Johansson
Sr. SQA Engineer
Message 3 of 3

Thanks, Lars.


I've been able to get C4R and PAC back to working condition and am leaving the updates that show up in the desktop app alone for the time being. (FYI, I'm only seeing "Autodesk A360 Collaboration for Revit v1 for Revit 2017 at the moment, but earlier could see the PAC update as well). Autodesk support magically created a support ticket based on this thread and I'm working through the issue with the support agent.


When I tried to uninstall PAC from the Windows (10) Add/Remove Programs control panel the uninstall seems to proceed normally, but the PAC entry in the installed programs list remained. When I tried to uninstall it again I get an error that I unfortunately can't remember right now. It wasn't the expected error along the lines that "the program doesn't exist", and "do you want to remove it from the list"; It was something I've never seen before. Sorry, I can't remember and can't replicate it right now as I've got work to do today.


And, yes, I have Revit (via Building Design Suite Premium) 2016 and 2017 installed on the computer at the moment. At other points in the past I have had 2015 and 2014 installed as well though they have been removed for a few months.


If any new relevant information comes out of the the support session next week I'll update this thread.


Thank you,



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report