Revit Architecture Forum
Welcome to Autodesk’s Revit Architecture Forums. Share your knowledge, ask questions, and explore popular Revit Architecture topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Undo or Redo Because Elements are not editable.

4 REPLIES 4
Reply
Message 1 of 5
Anonymous
5230 Views, 4 Replies

Can't Undo or Redo Because Elements are not editable.

Since yesterday I've been encountering an error that I have never seen before: Can't Undo or Redo because elements are not editable. This occured when trying to fix an issue in a workshared model. It was verified that no worksets had been checked out, and the file had not been saved. This error forced me to have to restore an earlier version of the model. Now this behavior is occuring more frequently and I don't understand why undo would not be available given the conditions I've described. Nor has it ever been an issue for me up until this point and I can't figure out what is causing it. This is becoming a severe inconvenience and I need to know if something has corrupted in the model that would be causing this. Has anyone come across this before?

 

Thanks so much.

4 REPLIES 4
Message 2 of 5
ennujozlagam
in reply to: Anonymous

hi, have you tried this go to collaborate > worksets > highlight your name > editable > change to "YES" and see how it goes. hope it helps. thanks.





Remember : without the difficult times in your LIFE, you wouldn't be who you are today. Be grateful for the good and the bad. ANGER doesn't solve anything. It builds nothing, but it can destroy everything...
Please mark this response as "Accept as Solution" if it answers your question. Kudos gladly accepted.
Message 3 of 5
Anonymous
in reply to: Anonymous

I just had this happen as well.  A big inconvenience for me.  I've never seen this error message before.  I synced and it seems as though it will not let me undo past the last time I synced.  I don't recall this being the case in previous versions of Revit.

Message 4 of 5
jklynsma
in reply to: Anonymous

The method suggested by @ennujozlagam worked for me.

I have thought it to be standard Revit practice that, once you synchronize with Central, you can no longer "undo" changes from before the sync, so I cannot speak to that.

However, I encountered an unusual issue today where I jumped way back in my undo history (approx. 50 commands back). I had no issues undoing commands, and I was very careful not to perform any commands (as I always am). For some reason though, Revit would only allow me to redo a couple of the commands before I encountered this same dreaded warning, "Can't Undo/Redo User Changes Because Elements are not editable." No one else was in the model either, so I know that no one else had checked out any components that I had modified. I had thought I lost a couple hours worth of tedious work. 

I followed a slightly different procedure from that suggested by @ennujozlagam, as described below. I'm still not sure what caused this issue to begin with, but the procedure below fixed the issue for me (using Revit 2021).

  1. Go to Collaborate > Worksets (under Manage Collaboration)
  2. At the bottom of the "Worksets" dialogue box that appears, under "Show:", make sure all 4 checkboxes are checked (User-Created, Project Standards, Families, Views)
  3. Select EVERYTHING by either: selecting the very top item on the list, scrolling to the very bottom, and clicking the very bottom item on the list WHILE holding Shift; OR by pressing Ctrl+A
  4. To the right of the window, click the "Editable" button.
  5. Click OK.

It's worth noting that this may not work if others are actively using the model, as others may have views, families, worksets, etc. checked out.

Anyways, hope this can help someone.

Message 5 of 5
wyattkA8WVF
in reply to: Anonymous

This worked perfectly for me.  Step 2 was the key part.  I ended up having an undo/redo issue due to a silly mistake while making two central models to create versions of a project.  I had tried changing all my active worksets to editable, but didn't work.  After selecting all four boxes under the "show" section and making all those additional worksets editable as instructed by @jklynsma, everything worked perfectly. Thanks!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Forma Design Contest


Technology Administrators