Community
PowerMill Forum
Welcome to Autodesk’s PowerMill Forums. Share your knowledge, ask questions, and explore popular PowerMill topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Robot Plugin

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
fghadamli
853 Views, 6 Replies

Robot Plugin

All,

 

Is there any way to change the graphics for the Robot Plugin? when I bring the plugin up, there will be a severe lag so I would like to reduce the graphics specifically for Robot Plugin. Will appreciate your help. 

 

Best,  
Farhad 

Labels (2)
6 REPLIES 6
Message 2 of 7

@fghadamli   My suggestion for this would be to purchase a better graphics card.  It's recommended by Autodesk to use a NVIDIA Quadro graphics card with at least 2GB of fully openGL 2.0 compliant.  Robot is very graphics heavy as the robots tend to have a lot of components and moving parts.

 

 

Craig Burney
Senior Application Engineer
Design & Software International
Message 3 of 7

Hi @fghadamli 

 

Without details it is quite hard to know what is causing it, i have never seen lagging in PowerMill Robot.

Is it possible you share a screen recording of the issue?


I know that large mtd files can cause slow down in simulation, but is generic to powerMill and not to the plugin itself. But is this what you mean ? Slow simulation?

 

The only other option I can think of is to change Display settings.
Right mouse click on PowerMill Icon, Properties. then follow the steps on the image below.

This normally helps with making the icons size display correctly and NOT with issues like lagging.

PM_Display.png


I hope this helps.
Alex



Alexandre Pinto
Process Specialist
Message 4 of 7

Thanks @Craig.Burney_DSI 

I will look into this option

Message 5 of 7

@alexandre.pintoAGNAU 

 

Thank you for the instructions. 

Please see the video attached. If you notice, the mouse movement is much faster and after a while, Robot will start rotating. It was catch up in some incidents though. 

 

I will try the option that you mentioned. 

 

Best, 
Farhad

 

 

Message 6 of 7

Hi @fghadamli 

 

Thanks for the screen share.

 

This lag I have seen and experienced myself on my own PC in the past. I had this on a high end spec Dell with dual graphics card.

Does your pc have dual graphics card ?

I disabled in the Bios the Dual graphics card option and selected only the NVIDIA, and that solved my issue. I had this lag in PowerShape and not PowerMill but it looks the same.

 

Note: What you see is not a lag in PowerMill Robot but in PowerMill, it just so happens that you have a Robot mtd loaded, any machine tool model would have this behaviour as well.  

I hope this helps.

 

Alex



Alexandre Pinto
Process Specialist
Message 7 of 7
fghadamli
in reply to: fghadamli

@alexandre.pintoAGNAU 

Thanks for the recommendation. The dual graphics card is the root cause I guess 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report