Community
PowerMill Forum
Welcome to Autodesk’s PowerMill Forums. Share your knowledge, ask questions, and explore popular PowerMill topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PowerMILL Excel SetupSheet plugin

130 REPLIES 130
SOLVED
Reply
Message 1 of 131
michael.grenier4GVTU
14765 Views, 130 Replies

PowerMILL Excel SetupSheet plugin

Hi Everyone,

 

I've been working on another plugin last year that was just publicly released.  This one will let you create an excel template to export your setupsheets.  It gives you a bit more flexibility than the current setupsheet we have in PowerMILL.  On top of that, since the source code is available you can do whatever you want with it.  The plugin include a folder of sample files and some documentation as to how to use it.

 

I'm joining the pdf I made to give you an idea of what is available but also what can be done with it.

 

https://github.com/Autodesk/powermill-api-examples/tree/master/addin-excel-setup-sheet

 

Enjoy!

 

Michael



Michael Grenier
Senior Solution Engineer
130 REPLIES 130
Message 81 of 131

Agreed that closing PowerMill and changing the language is anything but a good workflow but is the easier way to make it work at this moment.  The reason why the language is causing issue is because some parameters are analyzing text behind the scene and the plugin is expecting specific words to be there.  If they are not (because they are in another language), it fails.  The plugin would have to be updated with whatever term is used instead of the english word to make it work.



Michael Grenier
Senior Solution Engineer
Message 82 of 131

At the end I solve the 2 issue.
1- I have learned how to debug a dll from VisualStudio 2019 :party_popper::party_popper:

2- I found the TEXT in english used to split the things and make Pmill crash.

I'm very happy and proud of myself!.

 

Best regards

Message 83 of 131
Antoine-L
in reply to: omartiz

@omartiz @michael.grenier4GVTU 

 

Same here, thanks to this plugin, debug mode in Visual Studio is now crytal clear  😉

 

Personally, I don't have any bug working with Office 365 and Pmill in french version.

Just out of curiosity, for those who get problems with non-english version, did you try to switch in english by typing "lang english" in command window without restarting?

 

Regards

Message 84 of 131
camA2TY5
in reply to: omartiz

Hi!

 

I have the issue with the language, i don´t know to use Visual Studio, as you found the "key" english words, could you help me founding these "key" words?

 

I will report the issue to my company informatic department, but I will like to give the best info I can.

 

Thanks

Message 85 of 131

Looking back at it, there are few places where changes would need to happen.  There is a method called GetModelsLimits which prints the model size into a string var and then it's analyzed to get the values, but it looks for key words like "Minimum" which varies based on the language.  There is also another one similar for GetToolpathLimits.  TPSpecificParameters also has some names that would need to be changed to represent the correct toolpath name in your language.  There might be more you would see while debugging but those are the one that comes to my mind.

 

Hope this helps!



Michael Grenier
Senior Solution Engineer
Message 86 of 131
757044275
in reply to: Antoine-L

It's a good idea!!!
I just used your suggestions.
In the Generate_click Added a macro command to switch languages
and in the end of the click event to switch back。
thank for your
Message 87 of 131
camA2TY5
in reply to: 757044275

Hi

 

I don´t know nothing about Visual Studio, to make that macro for the language change y have to uninstall, change the code and install it again?

 

Thanks 

Message 88 of 131
757044275
in reply to: camA2TY5

My method is to modify the plug-in source code, which needs to be operated in the vs project. It is recommended to learn C# or VB language before modifying the plug-in, otherwise you will be helpless. good luck

Message 89 of 131
757044275
in reply to: camA2TY5

My method is to modify the plug-in source code, which needs to be operated in the vs project. It is recommended to learn C# or VB language before modifying the plug-in, otherwise you will be helpless. good luck

Message 90 of 131
camA2TY5
in reply to: 757044275

thank you!!

 

I`m on it...

Message 91 of 131

Hi @michael.grenier4GVTU,

I have tried record video about the issue I have, But it looks like I miss some information when I generate Excel Setup sheet.
https://autode.sk/367XpzV

Not listet correct.
What control what?
Same toolpath name came 3 times.

Hope it make sense, I attach excel file I have used + link to Project.

https://we.tl/t-MGkEv2PBHS


Thanks,
Jacob

Message 92 of 131

Hi Jacob,

 

I think I know what the problem is.  When you build your tool list or operation list, you can't mix tool. and toolpath. parameters.  In your current template you are which confuses the plugin.  I'm uploading 2 tempaltes back, one for a tool list and one for an operation list (which I believe you are really looking for).  Also joining the parameter pdf just in case you didn't have it.

 

Hope this helps.

 

Michael



Michael Grenier
Senior Solution Engineer
Message 93 of 131

Hi @michael.grenier4GVTU ,

 

I tried the attached (ExcelSetupSheetInstaller_2.zip) installer and enabled the plugin in PowerMill Ultimate 2023.

 

When I try to run the plugin to generate the setup sheet. Immediately PowerMill crashes without any crash notes. 

 

Am I going wrong somewhere. Also I have attached the powermill file for your kind reference where I am trying to generate the excel setup sheet for NC program 1005. 

Message 94 of 131

Thanks for sharing the project, it always helps a lot.  That said, it's not easy to debug without having your excel template you tried using as the problem can come from any parameter used in it.  I did try one of the sample one I ship with the plugin and could see it was firing an error on the uncompupted toolpath.  When toolpath 3 was removed, everything went through without any problem on my end.  The reason why this error was fired up is because my template was looking for min/max values of the toolpath, which are not available when the toolpath is not computed.  It might be a different error on your end but this is where I would start.



Michael Grenier
Senior Solution Engineer
Message 95 of 131

Hi @michael.grenier4GVTU 

 

This time I tried this with another powermill project with very few computed toolpaths. Still powermill exits abruptly without any error pop-ups. Also please see the attached excel template files and the powermill project.

 

In the powermill project I was trying to export excel setup sheet for NC program 1005. 

 

Attached also video file for your kind reference. 

 

Could you let me know how I can resolve this issue. 

 

 

Message 96 of 131

I have no problem exporting that project either.  I also can't see in your video what template you used as there are multiple xlsx files in the plugin folder you sent back.  Did you look at the option page from the plugin window and select the desired template as shown on the following picture?  From your video, it feels like it's trying to open a file that doesn't exist with Excel.  And I guess you have microsoft excel installed on this pc?



Michael Grenier
Senior Solution Engineer
Message 97 of 131

Hi @michael.grenier4GVTU 

 

Yes I use Microsoft Excel that comes with office 365.

 

At first the templates files where in the default installation location which the plugin had already referenced correctly. And when I opened the excel file to investigate, I found that the template file was in read only. I changed the location of the template file to a folder in the desktop where the template file became editable. Still when the template was referenced in the plugin options , powermill still crashes (Please see the video)

 

Should I reinstall the plugin with a different installer. If so could you share the same. 

Message 98 of 131

That’s interesting, this is the same template I used for testing earlier.  I have not modified anything in this plugin in a long time so I don’t see what rebuilding the installer would change honestly.  What regional settings are you using?  The plugin is comma, dot sensitive so maybe that could be why it’s not working on your end.  Also, have you run other plugins successfully in Powermill in this pc?



Michael Grenier
Senior Solution Engineer
Message 99 of 131

Please find attached file showing the regional settings in my computer. Is the attached file what you were asking for ? 

 

Also yes other plugins used to work fine in the system. The Robot plugin works perfectly fine. 

Message 100 of 131

Regional format is what I was looking for and you are set to the same as me so that is not the problem either.  Have you ever run another plugin?



Michael Grenier
Senior Solution Engineer

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report