Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Very slow sampling (when analysis overhangs)

3 REPLIES 3
Reply
Message 1 of 4
infinityx93
1848 Views, 3 Replies

Very slow sampling (when analysis overhangs)

Hello everyone, I want to generate some tree support in meshmixer for the model, but it takes too much time for "sampling" step(about 40mins) and meshmixer didn't load my CPU for maximum(only 8-10% usage, 300-500MB of memory).
I try to set high priority in Task manager didn't help at all.
Basic rabbit model does almost instant.
Can anyone help speed up this program?
or its pure hardware problem?

my conf: CPU: AMD Ryzen 2600x, 16GB RAM, Video: AMD R9 380 2GB, OS: Win64PRo

3 REPLIES 3
Message 2 of 4
MagWeb
in reply to: infinityx93

Should not be a hardware issue in your case.

The reason for the fact that MM doesn't use the full power of your machine is that certain tasks can't use multi threading.

That said - 40 min seem to be a pretty long computation time to me. What's your mesh density (see vertex and triangle count at MM's  bottom right)?.

To increase speed you might try a version of the model with lower resolution (e.g. export a lower subdivision level from a third party app or create a MakeSolid version of it) to generate the supports. After you generated the supports replace the low res version with the high res one...



Gunter Weber
Triangle Artisan

Message 3 of 4
infinityx93
in reply to: MagWeb


@MagWeb wrote:

Should not be a hardware issue in your case.

The reason for the fact that MM doesn't use the full power of your machine is that certain tasks can't use multi threading.

That said - 40 min seem to be a pretty long computation time to me. What's your mesh density (see vertex and triangle count at MM's  bottom right)?.

To increase speed you might try a version of the model with lower resolution (e.g. export a lower subdivision level from a third party app or create a MakeSolid version of it) to generate the supports. After you generated the supports replace the low res version with the high res one...


origin stl: vertices:262324, triangles:731696
after Edit->Make Solid vertices:996955, triangles:1992390
"Make solid" seems to be worked(sampling step now fast), but now "pruning" step takes a lot of time(depending on settings for supports), something about 10 to 30 minutes
making solid with low settings(solid accuracy:128, mesh density:128), accelerates "analysis", but does not create support for the wings
2019-06-12_17-37-15.png

Message 4 of 4
MagWeb
in reply to: infinityx93

Are you sure you need an angle of 60° to be supported. Know there are certain materials needing more support but for standard materials 45° should be enough (at a FDM)

I wonder why there are no supports at  all at the visible wing. Are you sure the model fits into the set printers volume? MM build supports only within that area.

731696 tris should work. Did you check whether there are some mesh errors in the original mesh(ANALYSIS/Inspector)?

On thin parts as the wings and a low resolution voxelisation as done by MakeSolid has problems of course. You might try its SolidType = Accurate. This allows to set a MinThickness. If lower it thickens the mesh.

But the either problem seem to be the wings which span a big area to be supported. Did you consider to cut them off and print as separate pieces oriented more vertically?



Gunter Weber
Triangle Artisan

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report