Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

stl repair

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
pixelworks
735 Views, 5 Replies

stl repair

Other than using Tinkercad, I am fairly new to working with 3D files. Tinkercad is great for doing small things, but for more complicated work I am trying to learn how to do things better with Meshmixer. I am just beginning with Meshmixer, so forgive me if I do not have the terminology correct. At any rate, I have a portion of a space station that I am trying to repair to the point where I can print it out.

 

Screenshot 2023-10-21 165851.png

 

I am not looking for anyone to do all the work for me, I would just like some advice as to how or where to start...  it is hard to google for help when many of the terms are unknown to me. Sorry for the ignorance.

 

Aside from the loose polygons that form the details and texture on top of the object's surface, the main problem is that the stl has many polygons that form the outside surface are not connected or only loosely connected, and there are openings between them that need to be closed. Beyond that, the entire "inside" needs to be solid. I have tried working with Face Groups to try and delete the inside as well as to correct this using Edit>Make Solid but the first did not do anything (due to my not really knowing what I am doing) and the second, in doing so I lose the majority of the surface detail. How do I best "fill-in-the-gaps" and solid-out the interior?  

 

Thanks for any advice in advance. 

 

[Edit]: ok for some reason I cannot upload the stl to this post, I will try to follow-up on that in another post.

5 REPLIES 5
Message 2 of 6
pixelworks
in reply to: pixelworks

I get an error when uploading the stl file:

 

the attachment's test.stl content type (application/vnd.ms-pkistl) does not match its file extension and has been removed.

 

I exported it  as stl from meshmixer, any ideas what I am doing wrong?

 

[edit]: I exported the file as obj, that seems to work. 

Message 3 of 6
hfcandrew
in reply to: pixelworks

This model has thousands of errors. This is beyond what Meshmixer can handle.

Windows '3D builder' has the best auto-repair out there. Better than programs that cost thousands a year to license. And no one really knows about. I used this.

 

I loaded your original model and converted to inches, then back to millimeters, then did Edit>Close cracks, which helped a bit. Then aligned it back to the origin  because it was way off. Then exported and loaded into 3D Builder, select the units as millimeter, then it automatically runs the autorepair (ran for about 7 minutes), then exported again. Worked great. Now you just need to scale it to whatever size you need for your print.

 

 

Before:

hfcandrew_0-1698072395079.png

 

After:

hfcandrew_1-1698072481452.png

 

btw the model still has two bodies, the centre piece is floating and not connected:

hfcandrew_2-1698072571581.png

 

You can run Edit>Seperate shells, to see.

 

Message 4 of 6
pixelworks
in reply to: hfcandrew

Hi Andrew,

Wow, that is amazing. Yes, it has so many errors many editors won't even load it. Thank you for the tip regarding MS 3D-Builder, I will check it out. And many thanks for taking the time to help! 🙂

 

Do you mind my asking, why was the first step of changing to inches and back to millimeters needed? And what do you mean in the next step by "aligned it back to the original"? 

Message 5 of 6
hfcandrew
in reply to: pixelworks

Almost a year later, better late than never, haha.

 

The algorithms of 3D Builder and MM tend to work within meaningful changes in a 3D printing sense, so component fractions of a mm will be seen as noise and removed. your entire model came in scaled wrong as 1.26mm long. My best guess was it maybe should have been 1.26 inch. I prefer mm over inches.

 

And I prefer things to be aligned at the 'origin' (0,0,0) for simplicities sake.

 

 

Message 6 of 6

Hello, @pixelworks,

 

Uploading the STL failed because the file type is/was registered incorrectly on your computer at that time. Your browser interpreted that incorrect registration and then told our forum it was about to upload a different type of file than it was about to send. So, based on the involved technicalities it would be grossly unfair to say you were actually doing something wrong even though that it was caused by something on your computer. Anyhow, this should no longer happen, but if this is still an issue for you, by all means let me know.

 

By the way, the thousands a year free Netfabb Basic repaired that file in only a few seconds, and with less introduced deformation still than Windows 3D Builder. Scaling was still necessary, though, as OBJ, like STL, is a unitless format. If its triangle coordinates say -2.234454563 -3.223611668 -4.956737829 (try opening an OBJ in a text editor), then that could be millimeters, inches, Unreal units, bananas, Olympic Empire elephant jet fields … Netfabb, too, would assume millimeters where a lot of detail could end up getting mistreated due to absolute values for the various parameters and thresholds of its repair script actions.

 

 

Kind regards,
Steffen

 




Steffen Anders

Autodesk Netfabb Team

Netfabb resources: Online HelpNetfabb knowledge baseForumsHomepageYouTube

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report