Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Smooth Boundary Borders In Transparent/Translucent

5 REPLIES 5
Reply
Message 1 of 6
sarf2k4
529 Views, 5 Replies

Smooth Boundary Borders In Transparent/Translucent

Hi,

I recently discovered that I turned on basic rendering and unable to go into transparent/translucent object. However, turning the option off do enable me to use the shaders but the orange boundaries made the highlighted orange in smooth boundary option became transparent/translucent. Turning on the basic rendering option do solve the problem but I'm unable to use shaders for the transparent/translucent object.

 

How can I have both shader enabled but without smooth boundary highlight becoming transparent?

 

{1CBE922A-63EC-4B28-B94D-36D6275B705B}.png.jpg

5 REPLIES 5
Message 2 of 6
MagWeb
in reply to: sarf2k4

This seems to be a graphics card drivers issue. To render things properly the GPU driver needs to support Qt 5 (Qt is a  framework MM uses to render stuff). So please check if you can update your graphics driver. Maybe  a lacking driver was the reason why you enabled basic rendering ? Maybe you also try MM 3.3 instead of MM 3.5 which needs less requirements concerning GPU.

Anyhow. This is just a temporary rendering glitch. As soon as you accept the tool you should find rendering being fine again.



Gunter Weber
Triangle Artisan

Message 3 of 6
MagWeb
in reply to: MagWeb

Maybe you can get rendering in SmoothBoundary by switching on wireframe rendering temporarily (hit W to toggle on/off).

Also disabling EnableAnti-AliasedRendering and ShowViewCube (>Preferences>General tab) might help?

 



Gunter Weber
Triangle Artisan

Message 4 of 6
sarf2k4
in reply to: MagWeb

Turning on wireframe during Smooth Boundary operation stays the same where the grey coloured shader/faces became orange translucent even with viewcube and anti-aliasing disabled.

 

I need viewcube to achieve more zoom as I work with precision, reset view to home (probably that what's you call it) with V enables me for more zoom. Disabling viewcube, I can't zoom further.

 

I am on the latest nvidia driver of v419, should be stable recommended update by nvidia.

 

I also switched gpu rendering to nvidia instead of integrated. Using GTX950M

 

My meshmixer is version 3.4.35, year 2017 from About Information.

 

I think I can live with basic rendering

Message 5 of 6
MagWeb
in reply to: sarf2k4

Some tools need/use transparent shader (e.g. PlaneCut, Align, MakePattern, an object set as Target a.s.o)... So BasicRendering is not an optimal solution.

 

Just some hints about navigation without ViewCube.

- In the Hotbox (Hold down Space) you can enable Snap:

Ohne Titel.jpeg

If active (dark) the cam snaps to nearby main directions (e.g. Top, Left, Right...)

 

To zoom in closer than the nearby clipping plane allows: SELECT the area of interest and do menu: View/RecenterView.

Now the selection is used to fit to view and also the clipping plane is reset relative to the selection.



Gunter Weber
Triangle Artisan

Message 6 of 6
sarf2k4
in reply to: MagWeb

For now I'm good with basic rendering, even for plane cut and others. I never understand what the camera stuffs that you pointed out like what are their differences between each.

I also posted a question here https://forums.autodesk.com/t5/meshmixer/over-zooming/m-p/8408728#M492 about zooming without clipping the model, I often use recenter view (V hotkey if viewcube enabled) and the idea of going to the menu bar to always recenter view is so bothersome because of 2 clicks away instead of V at the keyboard and quickly navigate to the desired point.

 

Thank you for the solution on the shader and basic rendering option you pointed out

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report