Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meshmixer STL cut plane results in rough "plane" surface

4 REPLIES 4
Reply
Message 1 of 5
thomasbrooksXVYWG
1078 Views, 4 Replies

Meshmixer STL cut plane results in rough "plane" surface

I am trying to cut up an STL, and when I do so, the "cut plane" has a rough surface and is clearly not a plane. I don't know why this is happening. It is important that the cut plane result in a flat surface for this item. A picture of cuts and the settings I use while performing a cut plane command are attached. The STL was non-manifold at first, so I turned it into a solid with maximum mesh density to ensure it maintains its shape which is important. This high density STL is what I am using cut plane on.

4 REPLIES 4
Message 2 of 5
MagWeb
in reply to: thomasbrooksXVYWG

Think this is caused by rendering only. Your geometry instead should be fine and if you'd export it it will look like expected (hopefully).

 

If you did the cutting after MakeSolid (which may not result in sharp edges if you don't set it right):

 

Seems you are currently using VertexNormals as MeshNormalMode (which smoothes the rendering appearance). I recommend to use FaceNormals instead. This shows the geometry "as it is".

(To complete options: GroupNormals(Default) is some kind of a mix. It uses VertexNormals inside FaceGroups but FaceNormals on the boundaries of the group)

 

Two ways to set this rendering mode:

- >Preferences > General tab > in MeshNormalMode section set FaceNormals

- open Hotbox (hold down Space at your keyboard) > in its Mesh section in Normals click the middle button (the one were the sphere shows the triangles)

 



Gunter Weber
Triangle Artisan

Message 3 of 5
thomasbrooksXVYWG
in reply to: MagWeb

Thank for the answer! Unfortunately, it isn't just a rendering thing. I have attached a picture of a "plane" side of a piece when I export it from meshmixer then import it into my slicer.

Message 4 of 5
MagWeb
in reply to: thomasbrooksXVYWG

Hmm... using MM since years. Never got such a result using EDIT/PlaneCut and it's most probably my most used and a pretty robust tool...especially if you'd MakeSolid before....

Maybe PlaneCut didn't fill the cut (may happen) and you filled it another way (e.g. selecting the open boundary and used EraseAndFill or Inspector or Make(ing)Solid again....)?

If not: There should be something wrong with your source mesh. 

Can you post it somewhere an send me the link via PM?

 



Gunter Weber
Triangle Artisan

Message 5 of 5
thomasbrooksXVYWG
in reply to: MagWeb

The problem occurs if I separate shells then cut more planes. If I cut all the planes then separate shells at the end it works great. That's the work around. Thanks for your comments!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report