Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meshmixer reduce not working

4 REPLIES 4
Reply
Message 1 of 5
dvdsmthdvd
1399 Views, 4 Replies

Meshmixer reduce not working

I can't seem to get the "reduce" command to actually reduce anything. I've tried reducing triangle budget and percentage, and neither will reduce the number of triangles, even after clicking accept and exporting my model is exactly the same. This is on a Macbook Pro. Any suggestions?

4 REPLIES 4
Message 2 of 5
MagWeb
in reply to: dvdsmthdvd

Hmm, I'm on macOS too and this is a unknown issue for me. Which version of MM do you run on which macOS version? Are there some mesh errors (non manifolds issues or flipped faces) on your source mesh?

(if possible post a zipped file as an attachment)

 

Just to explain Reduce and to make sure you do it right:

Reduce is based on a selection. Meaning it only affects the selected area (and as you can do a selection on a single object only it affects the active object only). If you want to reduce a whole object make it the active one by clicking on it. Hit Cmd+A to SelectAll.

Now enter Edit/Reduce. It's a good idea to switch on wireframe rendering by hitting W (this is a toggle key).

The slider values for the different modes (ReduceTarget) may be confusing:

On Percentage-mode max reduction happens with Percentage at 100% (which is righthand slider's range)

On TriangleBudget max reduction happens with TriCount at 3 (which is lefthand slider's range)

On MaxDeviation-mode max reduction happens with MaxDeviation at it's righthand limit.

Anyhow as soon as you pull an active slider you should see a change on the wireframe in the selected area if there are faces which can be reduced . If there's a partial selection only, a certain triangle number is needed to keep the connection to the edges of the selection border. At extreme: If you selected a single or  a few faces only MM might not be able to collapse these without causing a crack in the mesh.

Also if there are many small face groups (each only a few faces) on the mesh and PreserveGroupBoundaries is enabled this might forbid a reduction.

----

Besides Reduce you can also do a reduction in certain modes of Remesh (all but LinearSubdivision):

On RelativeDensity and AdaptiveDensity use a negative Density percentage.

On TargetEdgeLength set a higher EdgeLength. 

Against Reduce this way allows e.g. to SmoothGroupBoundaries and to PreserveSharpEdges

 



Gunter Weber
Triangle Artisan

Message 3 of 5
grayed
in reply to: dvdsmthdvd

I'm having the same issue on Win10, with a relatively fast Nitro5 with extra RAM.  The file I'm trying to reduce is the .obj file at https://www.thingiverse.com/thing:4534053/files.  Nothing changes it.  Yet I've done this with many other files with no problem.  Why issues with this one?

Message 4 of 5
MagWeb
in reply to: grayed

There are some non manifold issues on the source mesh. MM highlights those issues with red dots after you loaded the mesh.

You need to repair it using ANALYSIS/Inspector first.

After you did AutoRepairAll > Reduce (or Remesh) should work.



Gunter Weber
Triangle Artisan

Message 5 of 5
lomokoljonathan
in reply to: MagWeb

Facing this problem too. The brushes just stop working yet they have been all fine. First the adaptive which I use the most then the reduce too.

Solution to this was check the enable refinement in the Refinement drop down.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums