Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Meshmixer Crash On Launch - Error Loop!

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
fyarvis
564 Views, 2 Replies

Meshmixer Crash On Launch - Error Loop!

Hello all.

 

I'm attempting to run Meshmixer on Windows 10. It worked just fine until a few days ago, then stopped out of the blue (not sure if there was a Windows update in there to bork it). After going through the FAQs, installing v3.3 (same problem), and some general mucking about I think I found an error, but the program itself is preventing me from fixing it.

Initially, when launching Meshmixer (by opening an associated file, clicking on a Desktop shortcut, or launching directly from the Meshmixer directory) it did not display any window or give any error message. Hovering over the Meshmixer icon on the taskbar would show a plain white square where the app preview should be. 

I tried going into the meshmixer.ini file and turning off all of the networking module commands (CheckUpdates, etc.). This resulted in the error message shown in Screencap 2. Regardless of what you click on that error message, the program then resets the "UserPreferenceforDataCollectionSetV3" back to "True", without actually launching the program, so I end up back where I started. 

Is there some way to circumvent this error so that I can permanently turn off the "UserPreference..." variable through the help menu?

 

Also, it should be noted that there is still a white screen where the app preview should be when the above error message pops up (see Screencap 3); would that indicate that the issue preventing Meshmixer from launching is different from the networking module problems I described above?

2 REPLIES 2
Message 2 of 3
hfcandrew
in reply to: fyarvis

  • Delete the .ini
  • Disconnect your computer from your network/internet
  • Make sure a character in one of the directories of MM is not a non-english/latin letter
  • Rollback windows
Message 3 of 3
fyarvis
in reply to: fyarvis

@hfcandrew Thank you very much! Deleting the .ini and disconnecting from the internet caused it to launch without issue (there were no odd characters in the directories already). Rolling back Windows was not required.

Shortly after the initial fix I reconnected to the internet and then attempted to open Meshmixer again (without deleting the .ini file first this time); it opened without issue. This may imply that the .ini file was the issue, but I haven't tested enough to be 100% sure. I'm posting these additional notes in case anyone else has a similar problem.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report