Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Make Solid degrades the original model

9 REPLIES 9
Reply
Message 1 of 10
timK43CV
10471 Views, 9 Replies

Make Solid degrades the original model

Hi there! New Meshmixer user here.

 

I'm trying to repair some 3D models and Meshmixer was recommended for ease of use and functionality. So far I'm liking it quite a bit; however, I did encounter a problem.

 

What I'm trying to do is cover some holes in my models generated elsewhere. It looks like this after import (.obj file):

image.png

As can be seen, there are lot's of holes in the sides of the container. 

Next I add box primitive and size it to roughly cover the problematic wall:

image.png

Then select both objects in the Object Browser

Select "Combine"

I need it exported as a single mesh (rather than separate shells).

So next I select "Make Solid". And that's where the original portion of the model gets all messed up. Looks something like this:

image.png

Messing with the settings (like changing type to Accurate, increasing Solid Accuracy and Mesh Density, etc.) helps a bit, but overall the model still looks worse (more/bigger holes) than the original. 

 

The answer might be in the settings, but I can't seem to find the right combination.

Any suggestions on dealing with this?

Any other way to fix those holes other than Draw a Box -> Combine -> Make Solid?

 

Thanks in advance for the help!

9 REPLIES 9
Message 2 of 10
MagWeb
in reply to: timK43CV

The metal sheets of the container are very thin compared to its overall size.

MakeSolid builds a virtual 3D grid. Each cubic cell of that grid hit by a single surface results in a vertex. Two surfaces (the front and the back of a sheet) inside a single cell are contrary data and therefor there will be no vertex.

You need to increase SolidAccuracy and MeshDensity so the resulting cell size is smaller than the sheet's thickness. You can set higher values than the sliders' ranges by a numerical input clicking on the displayed  numbers.

Basically your way to close the holes via an inserted object should work if the cells are small enough. But you loose texture that way (MM converts texture to PerVertexColor running MakeSolid.

 

A way to keep the texture is to isolate  inside and outside of the container.

Go to SELECT and select something (that's only a seed selection). Now run Modify/SelectVisible and hit Y to make the selection a separate object B. (Check if you selected and separated parts of the inside (looking through a hole. If yes select those regions, separate and combine them with the source mesh again) Repair interior open boundaries of this new object B using ANALYSIS/Inspector by clicking the blue marker spheres one by one until only outer open boundaries are left over. Now Combine again and run EDIT/CloseCracks to weld again. 

Repeat this on another aspect of the container aso...

 



Gunter Weber
Triangle Artisan

Message 3 of 10
ody.chetty
in reply to: MagWeb

Hi there. I am currently facing a similar problem 

I have a big file that needs to be cut into pieces so that I can print it on my machine 

However when I import the .stl file into meshmixer it automatically makes it solid and hence I lose my finer details 

I did try to increase the Mesh density as well as the Accuracy but none of which bring back my details to the original state. Is there anyway I can fix this or prevent it all together 

Thank you in advance

Message 4 of 10
MagWeb
in reply to: ody.chetty

There's no auto MakeSolid when you import a mesh file as a STL.

However what you're facing might be a rendering issue.

See here.



Gunter Weber
Triangle Artisan

Message 5 of 10
ody.chetty
in reply to: timK43CV

Hi Thank you for that, however my pieces still seem muddled is there by any chance something else I can try 

Or is there any other explanation 

Message 6 of 10
ody.chetty
in reply to: timK43CV

Hi, actually your tip worked out quite well and I was able to solve the problem 

 

However now that it filled out I find I am unable to make it solid without losing these details which is fine 

Until I try to cut the stl 

The file that I have seems to be hollow inside and whenever I try to cut it 

It is hollow inside and it cuts off random, little pieces and separates them separately from the larger body 

 

Is there anyway I can fix this without makingy object solid again 

Again thank you so much for the help!

Message 7 of 10
ody.chetty
in reply to: MagWeb

 

Hi, actually your tip worked out quite well and I was able to solve the problem 

 

However now that it filled out I find I am unable to make it solid without losing these details which is fine 

Until I try to cut the stl 

The file that I have seems to be hollow inside and whenever I try to cut it 

It is hollow inside and it cuts off random, little pieces and separates them separately from the larger body 

 

Is there anyway I can fix this without makingy object solid again 

Again thank you so much for the help!

Message 8 of 10
MagWeb
in reply to: ody.chetty

MakeSolid always starts with default settings (which are not enough to give enough resolution in most cases). You might need to increase SolidAccuracy and MeshDensity (take care of the cell sizes displayed below the sliders: These should be almost equal) and to hit Update after that. Note: You can get values above the sliders' max by numerical input via keyboard into the value fields. Also: Keep these values as low as acceptable.

 

If you cut an object via EDIT/PlaneCut you perform a global cut. (Means: In case of a human body: the cutting plane might hit the hands while you are trying to cut the waist.) This might result in tiny pieces....

There's a non global PlaneCut to based on a selection in SELECT > (select the lion to cut through) > run Edit/PlaneCut within the SELECT tool options.



Gunter Weber
Triangle Artisan

Message 9 of 10
ody.chetty
in reply to: MagWeb

I tried to use the solid tool but it destroys my details entirely even when I adjust the accuracy and density 

It tends to cut off parts even where I haven't touched with the cutting tool

Message 10 of 10
MagWeb
in reply to: timK43CV

Can you post a small example zipped version of a .MIX? Plus/or some screenshots of your workflow (e.g. imported file, MakeSolid preview after refining the densities). If MakeSolid "cuts off" some regions: The connection between te regions might be too thin at the given resolution.



Gunter Weber
Triangle Artisan

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report