Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue with Mac and Meshmix function

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
norbertut
574 Views, 2 Replies

Issue with Mac and Meshmix function

Hi, I am writing on behalf of someone else that is not fluent in English, to help him out with this strange issue with a Mac.

I use Windows so unfortunately I can only pass in the info, and cannot check myself.

 

The issue only happens with Meshmix when adding objects in the scene.

 

The interface suddenly changes and renders black with no objects visible there, and the View Cube changes its color to the same texture of internal sides of triangles.

If we close and open again, interface shows correctly again.

 

Better to show than to explain, so here's a video of the steps and the issue.

 

https://vimeo.com/586669930/5f2ede2bdb

 

Regarding system settings:

O.S.: macOS Big Sur version 11.5.1

Computer: MacBook Pro

 

Anyone has seen this before? or any suggestions how to avoid it?

Thanks!

Labels (2)
2 REPLIES 2
Message 2 of 3
MagWeb
in reply to: norbertut

This is a crash of the rendering.

If it's an older MacbookPro a too poor GPU might be the reason. In this case try MM 3.3 instead of 3.5.

 

Unfortunately the video doesn't show if there's some printer set. Often if there's no printer selected such crashes occur. Via menu: View enable ShowPrinterBed. If the box at top/right returns NoPrinterSelected: Choose one from the dropdown list. 

 

Sometimes disabling ViewCube rendering via menu: Meshmixer>Preferences>General tab disabling ShowViewCube solves such crashes. Also check if EnableAntiAliasedRendering is checked: If yes turn it off.

 

Another fix might be to delete meshmixer.ini  in MacOS/Users/MagWebPro/.config/Autodesk (note: .config is hidden by OS defaults so one needs to set macOS to show hidden folders) while Meshmixer is shut down. On its next start MM will restore a default meshmixer.ini.

 

Worst case solution (as it disables stuff like transparency shading needed for some tools) is to enable EnableBasicRendering in Preferences.

 

 



Gunter Weber
Triangle Artisan

Message 3 of 3
norbertut
in reply to: MagWeb

Thank you very much @MagWeb for all your knowledge.

The last option, to enable Basic Rendering, sorted out the problem. 👍

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report