Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Importing and orientation

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
paulHNAV3
834 Views, 2 Replies

Importing and orientation

When I use to import meshmixer would import in the orientation I saved the file. Now when I import it's in a totally different orientation, is there something wrong with the way I have my preferences? 

2 REPLIES 2
Message 2 of 3
hfcandrew
in reply to: paulHNAV3

Maybe.

 

Look under preferences to flip Z-Y on export/export.

 

hfcandrew_0-1589207854240.png

 

Message 3 of 3
MagWeb
in reply to: paulHNAV3

Most likely you're facing the different Up conventions issue. Construction CAD applications (coming from extruded 2D floor plans where X and Y were used as the horizontal plane) use Z as the third and therefor up-dimension. There are other more artistic applications where 3D started from a vertical image on a monitor (here the monitor's width X and height Y is thought to be a vertical plane). Here Z is the depth and therefor the XZ plane is the horizontal plane while Y is the up direction.

 

MM uses Y as the vertical dimension. So if you import an object you did in a Z-Up application it appears rotated 90° (oriented horizontal instead of vertical). Same if you export from MM and import to a Z-up app (as most machining softwares which are Z-up)

 

EDIT: Andrew is typing faster 🙂

For easier handshake there's an option in the Import dialog (and in Preferences) to flip Y/Z on Im/Export. Check this setting and your source/target application which Up direction is used.

 

If you're facing a different issue please recall - maybe some image?



Gunter Weber
Triangle Artisan

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums