Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Imported stl files look like all sharp edges are eroded.

20 REPLIES 20
SOLVED
Reply
Message 1 of 21
jmcd55
24209 Views, 20 Replies

Imported stl files look like all sharp edges are eroded.

I am completely new to mesh mixer so...   when i import an stl model into mesh mixer it appears like it is eroded away on all surfaces. what do i need to do or change to fix this problem?  I've included a couple of screen shots .  the one (screenshot (2) .png shows what the model should look like and the other shows what mesh mixer is doing.  Thanks 

20 REPLIES 20
Message 2 of 21
MagWeb
in reply to: jmcd55

That's only a rendering issue on a low poly object.

 

Press space to open the Hotbox and in its Mesh/Normals section click on the sphere in the middle.

 

Or via menu File (Meshmixer in case you're on Mac)/Preferences> MeshNormalMode: set to FaceNormals        



Gunter Weber
Triangle Artisan

Message 3 of 21
jmcd55
in reply to: MagWeb

This was exactly the information i needed . Your solution worked beautifully. Thanks

Message 4 of 21
pkrog1
in reply to: MagWeb

It feels like this isn’t just a rendering problem. I’ve had this issue countless times, and although the display in Meshmixer looks fine after the solution provided, the model is still “eroded” when I export it as an OBJ to be printed on a 3D printer.

Message 5 of 21
MagWeb
in reply to: pkrog1

Yes and much more No. Mesh processing  deals with coordinates made of numbers only. Basically numbers stay the same on PC systems. But:

On Import MM converts world coordinates to a normalised coordinate space and back to world coordinates on Export.

These conversions may cause a minimal rounding error but it is most unlikely that your printer or your eye is that accurate. We are talking of a rounding errors  of about 0.00000003mm....

A different thing is if you do things like MakeSolid, Remesh or Reduce where the source surface coordinates are modified.



Gunter Weber
Triangle Artisan

Message 6 of 21
pkrog1
in reply to: MagWeb

I am afraid I don't quite understand your response.

I can make something extremely simple in a program such as Sketchup. Lets say a cube with a square indentation on one face. When I export it as an STL from Sketchup, it retains its shape. When i import it into MeshMixer, it appears eroded. I can perform the operation that was initially suggested here to make it regain its sharp appearance, but when I export the file out of MeshMixer into a simple format like OBJ, it returns to its eroded appearance. If I were to bring the original model directly from Sketchup, exported to STL, into a slicer, such as Cura, it would not appear eroded. Something about Meshmixer is altering the faces of the shape. Is there a setting that will allow Meshmixer to export the shape in the same state as it is displayed when I perform the solution provided above?

 

The "minimal rounding error" you speak of is evidentially not what i am seeing. It is making changes that affect objects with a diameter of 25mm. An icosahedron turns into a lumpy sphere.

Message 7 of 21
MagWeb
in reply to: pkrog1

3D files as obj and stl are simple text files storing coordinates

Let's look at a .obj file:

Ohne Titel.jpeg

The lines starting with v are points' coordinates(X Y Z)

The lines starting with f are pointers to the line numbers starting with V

So the first line starting with f constructs a triangle face (in this case) based on the points stored in the first, second and third v-line.

The second line starting with f constructs  a triangle face in this case based on the points stored in the first, 4th and second v-line. The order 1-4-2 instead of 1-2-4 (clockwise or counterclockwise) defines the direction the face's frontside points to.

a.s.o.

Now exporting that file (ignoring the rounding error) writes the same values to the same lines . That's it - nothing fancy. Well MM might add stuff like vertex normals, group definitions but these do not modify the geometry at all.

 

The only thing that comes to my mind:

Are you on a localisation where one uses a comma as the decimal separator AND use the PRINT module to send it to the slicer ? As PRINT uses a command line to pass the object to the slicer. Maybe your OS does an auto format conversion and switches commas and fullstops (my MAC did that running applications via its Terminal). In this case you might end up with full numbers in the slicer only (anything after the comma is ignored).

If so, you might consider to set fullstops as decimal separators in your OS formats settings.

If not: Please post a zipped input file and its MM's output result. 

 



Gunter Weber
Triangle Artisan

Message 8 of 21
ryanjolliffe
in reply to: MagWeb

I'm not the above poster, but I'm having an identical problem.
I use GB english (no commas as decimal places) but meshmixer displays the object differently than my slicer (Cura) and I'm currently unable to print the part this way.
Changing the view as mentioned above shows it correctly but after exporting Cura now shows the ruined model.

 

I have attached a zip file with the original file (Spinner_50mm_Back_v1.09.stl), the exported file from MeshMixer (Plane Base w Mesh Supports.obj) and a picture of the two in Cura.

Any help would be greatly appreciated, as I love the support generation in MeshMixer.

 

 

MeshMix.PNG

Message 9 of 21
MagWeb
in reply to: ryanjolliffe

This is a pure Cura rendering issue (does not affect slicing at all).

Seems they use  VertexNormals to render .obj imports while they use FaceNormals to import .stl...

No clue why they do this...

 

Easy fix: From MM export to .stl instead of .obj



Gunter Weber
Triangle Artisan

Message 10 of 21
LenK13
in reply to: MagWeb

I Had to get a New PC, and re-install everything. Meshmixer was showing some wierd renderings. Nothing was straight, did a quick search and found same symptom as "jmcd55" was explaining. Eroded looking files.  Followed your solution to HOTBOX via the spacebar. Selected middle target under "MESH" within the menu option, and Wa-La.!  All appears normal again.  

 

Thank you for sharing.  I was never aware of that spacebar HOTBOX submenu.  Been playing with Meshmixer for three years (Self Teaching) any and all hints, tricks, menu options etc. are extremely beneficial for a self taught user such as myself. 

 

GUNTER WEBER - You and your responses Sir, are definately appreciated.  

 

Thank you  -  LenK13

 

 

 

Message 11 of 21
zbysior
in reply to: MagWeb

Thank You!!!

Message 12 of 21
MagWeb
in reply to: zbysior

This is one of the most viewed topics here and some basic information for newbies.

So if anyone with the rights to do that reads this:

PLEASE PIN THIS TOPIC!



Gunter Weber
Triangle Artisan

Message 13 of 21

Pinned!




Steffen Anders

Autodesk Netfabb Team

Netfabb resources: Online HelpNetfabb knowledge baseForumsHomepageYouTube
Message 14 of 21
kmknights
in reply to: MagWeb

Thank you! This was so helpful! 

Message 15 of 21
thecooltool
in reply to: MagWeb

MeshMixer is reading the normals wrong!
I have loaded the same models in other apps and they render the lighting correctly BECAUSE they read the normals correctly.
STL files binary or ascii are just triangle lists.. no indices list.
They are simple files.
MeshMixer is not reading the normals correctly and it's trashing the lighting.

Message 16 of 21
thecooltool
in reply to: thecooltool

STLs are useless for anything but 3D printing.. There are NO UV coordinates for textures.
Just a normal vector and 3 vertices for each triangle in the model. Though it is possible to have N sided polygons, 3 sided triangles are all that I've seen in a STL model.
I have written readers for both ascii and binary and they are nearly the same format.
Fix the normal reader in MeshMixer PLEASE?

--== Sample from File ==--
solid "test"
facet normal -0 -1 0
outer loop
vertex -28.0069999695 4.xxx-xxxxxxxx 2.96840880765e-08
vertex -30.5200004578 2.7619998455 2.96840880765e-08
vertex -28.8999996185 5.xxx-xxxxxxxx 2.96840880765e-08
endloop
endfacet
facet normal -0 -1 0
outer loop
vertex -28.8999996185 5.xxx-xxxxxxxx 2.96840880765e-08
vertex -31.4050006866 3.6139998436 2.96840880765e-08
vertex -30.0340003967 7.0720000267 2.96840880765e-08
endloop
endfacet
facet normal -0 -1 0
outer loop
vertex -30.0340003967 7.0720000267 2.96840880765e-08
vertex -32.5209999084 4.xxx-xxxxxxxx 2.96840880765e-08
vertex -31.3969993591 8.xxx-xxxxxxxx 2.96840880765e-08
endloop
endfacet

Message 17 of 21

@thecooltool,

 

Meshmixer is currently not subject to continued development, so this quirk will remain until further notice.




Steffen Anders

Autodesk Netfabb Team

Netfabb resources: Online HelpNetfabb knowledge baseForumsHomepageYouTube
Message 18 of 21

That's too bad.
Is this open source? I never checked.

Message 19 of 21

No, it is not open-source.

 




Steffen Anders

Autodesk Netfabb Team

Netfabb resources: Online HelpNetfabb knowledge baseForumsHomepageYouTube
Message 20 of 21
thecooltool
in reply to: jmcd55

Wow.. such an easy fix..
Go to File --> Preferences and on the right under Mesh Normal Mode, Check Face Normals. STLs do not have a normal for each vertex.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums