Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to change MM autosave location?

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
neekk
1723 Views, 2 Replies

How to change MM autosave location?

Hi, I need to change the folder for autosave (redirect it to another location to free up disk space). I found meshmixer.ini but there is no line stating the autosave location. Any suggestion? I know that it's possible to turn autosave off, but I'm just wondering if there is other (right) option.

2 REPLIES 2
Message 2 of 3
MagWeb
in reply to: neekk

There's no option I know to set a separate path for the autosave folder only.

MM experts it to be a subdirectory of .../meshmixer. If autosave doesn't exist at that location MM will make that directory there.

By default this MM directory is at .../username/documents/meshmixer.

So'll need to move the whole meshmixer directory:

 

While MM is down simply move the meshmixer directory to a different location (maybe a different drive as well) where the current user has read and write permission.

Now launching MM will show that dialog. Click on Redirect and browse to the new location:

Ohne Titel.jpeg

Choose the meshmixer directory (do NOT use a different name for that folder).

Once you did that there's  a line added in meshmixer.ini in its [options] section storing the override path:

OverrideFilesRootPath=/Volumes/Storage_1/meshmixer

(Note this is a macOS path pointing to a different volume called Storage_1 and the meshmixer directory is at its root level).

Manipulating meshmixer.ini you could add such a line manually directly without using the Redirect routine above.

 

 

 



Gunter Weber
Triangle Artisan

Message 3 of 3
neekk
in reply to: MagWeb

Thank you! It works for me!
I simply moved the meshmixer folder to another disk then wrote down to meshmixer.ini that new override path and my problem was gone!
 
But I met with very strange restrictions, by the way.
This refers to the pathnames written to the meshmixer.ini, as I found out (for Windows, in my case):
- Slashes must be only left to right "/".
- No system environments.
This annoying but isn't surprising though. But the next one I found, is really beyond my comprehension:
- No capital letters in the LATEST folder name!!! (for the meshmixer.ini override path)
However, of course, you can have both, capital and lowercase letters in real names for folders - Windows will ignore the difference. But you must write it in lower case into meshmixer.ini.
 
For example: 
OverrideFilesRootPath=%USERPROFILE%\Folder\another - Folder\meshMixer Test
- won't work at all. There are all cases - system environment, slashes, and capital letters in the latest folder name.
OverrideFilesRootPath=c:/Users/Username/Folder/another - Folder/meshMixer Test
- won't work because capitals in the latest folder name, BUT!!! if you simply change it to lowercase (just for meshmixer.ini - not for real windows path) like this:
OverrideFilesRootPath=c:/Users/Username/Folder/another - Folder/meshmixer test
- it will work!!!
 
I hope this can be useful for someone.
 
Sorry for my weak English 😞
Thanks again.
Have a nice day!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report