Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Circular plane disappears when solidifying mesh

4 REPLIES 4
Reply
Message 1 of 5
vgilday
336 Views, 4 Replies

Circular plane disappears when solidifying mesh

I've made an STL file in blender. When I import it to meshmixer and size it up, everything is fine, but when I try to solidify it, the circular face at the bottom disappears. I've tried the different solid types, I've maxed out Accuracy and Density, and minimized Culling Threshold. I've practically tried every option in the solidify interface. Any advice?

Mind you, in Blender there are plenty of non-manifold edges, intersecting faces, zero faces, etc. There's just too many and I don't know how to fix them all. If that's the problem, any tips on how I should address that would be appreciated. I've already gone through and closed up anything that was actually unintended, but otherwise everything seems to be in good order, blender just keeps telling me it's not. I've installed 3d print tools in blender, but when I click "make manifold" it closes up ports I need for a switch and a charging board. I should note that there are rails that intersect with the bottom face, which I mean to meld into the bottom face when it prints.

Labels (1)
4 REPLIES 4
Message 2 of 5
hfcandrew
in reply to: vgilday

MM can do it. But there are many conditions of the mesh to satisfy before each tool will work. Every project and every mesh is a unique snowflake. Maybe your mesh density is too low or too high, or non-manifold, or normals are flipped or they are separated shells. I can't give too much insight and diagnose the problem without the .stl

Message 3 of 5
vgilday
in reply to: hfcandrew

Hey @hfcandrew , if you have the opportunity to give it a look, I'd appreciate it. I uploaded the .stl file. 

Message 4 of 5
MagWeb
in reply to: vgilday

The bottom of the tube comes with flipped normals. These surfaces point inside out. That's why MakeSolid will remove them.

You need to flip these surfaces: 

Run EDIT/GenerateFaceGroups (defaults should work)

Go to SELECT, enable AllowBackFaces and double click at one side of the bottom (with the pink stripe pattern) to select the bottom group. You will not see any effect as the invisible side of the surface is selected now but if you do Edit/FlipNormals the surface should change to a uniform color without stripes. Do the same on the other side of the bottom.

Now MakeSolid shouldn't remove the bottom.



Gunter Weber
Triangle Artisan

Message 5 of 5
vgilday
in reply to: MagWeb

Hey @MagWeb , thanks for your suggestion. I fixed the normals, but make solid is still removing the bottom faces.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report