Community
Meshmixer
Welcome to Autodesk’s Meshmixer Forums. Share your knowledge, ask questions, and explore popular Meshmixer topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Actual dimensions of scan in Meshmixer

4 REPLIES 4
Reply
Message 1 of 5
cgohse
2179 Views, 4 Replies

Actual dimensions of scan in Meshmixer

Hi all,

 

I have been importing my .obj files of scans and realised they have been scaled down a lot. And I need them to be in actual dimensions without me measuring it myself. People have said to change the workspace to meters before importing the scan for it to work but I can't seem to do it and find it. Any step by step instructions plssssss?

Thanks!

4 REPLIES 4
Message 2 of 5
MagWeb
in reply to: cgohse

Importing a .obj file MM reads its xyz-values only. You need to make sure that the current (or last used) scene you import a file to uses the same unit as your scanning software used.

 

Let's say you used inches to scan an object you need to set MM to use inches as its unit before importing the file.

To set MM to use a certain unit go to ANALYSIS/UnitsDimensions.

 

Now, if your scan is much bigger or smaller than the current scene, MM might ask you whether to resize an imported object to fit to a current scene. Say No if you want to get the object in its actual size.



Gunter Weber
Triangle Artisan

Message 3 of 5
cgohse
in reply to: MagWeb

Thank you!

 

I seem to have done it. Exported it as .stl and when I opened it in fusion 360 to do some customisation. Back to square one. Not to scale again. 😞

Message 4 of 5
hfcandrew
in reply to: cgohse

What type of 3D scanner are you using and is it calibrated correctly for scaling?

Message 5 of 5
paulRUXNZ
in reply to: MagWeb

I have attempted this and it simply freezes meshmixer. This is an issue for anyone using a Structure scanner from Occipital. Since the scanner only outputs OBJ format, there is no scale information.  Occipital states however that they use meters for scale. The only easy way(so far) I have found to preserve the scale of the actual scan is to open in another 3d program first. I use 3D builder, which comes preinstalled on Windows 10.  Simply open a new scene-->In settings, set units to meters-->Import 3D object-->Choose the OBJ file and it will appear and give you options of different units, choose meters-->Save as STL to export. Then you can simply open the STL in meshmixer or any other software and the scale issue should be rectified. 3D builder's software also does a good job of automatically removing noise picked up from your scanner.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums