Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Xgen strange behaviour when using density brush

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
olinadgisel
1375 Views, 5 Replies

Xgen strange behaviour when using density brush

Hello, I have a problem with xgen that I can't easily describe so I'll show what is wrong using screenshots.

 

Here is a model I'm working on and right now everything is fine with the hair.

Screenshot_2.png

But as soon as I try to use the density brush to add or remove some hairs, this happens

Screenshot_1.png

If anyone has any idea why this is happening, please help

Thanks you

Tags (2)
5 REPLIES 5
Message 2 of 6

Hello!

 

To me, that looks like a memory error, which xgen does a lot. 

 

Reboot, try it again. If it's still doing it, make sure "Interpolate from the current description" is on in your density brush, and then rebuild your CVs in the shape node. Sometimes Xgen forgets what width to make things. 😄

Message 3 of 6

Thanks for the reply! The rebuild CV button does revert the hairs back to their proper state, but using the density brush unfortunately still does the same thing. Restarting maya does sometimes fix the issue so I think I guess I can consider my problem solved.

Message 4 of 6
matteo_bacci
in reply to: olinadgisel

i have the same issue, in maya 2020.1, while in 2019,2 it is not hapenning.

 

it is impossible to paint density or deleting hair....i mean...fix it please....now i try deleting my pref folder to see if that fix the problem....

Message 5 of 6
matteo_bacci
in reply to: matteo_bacci

then i have another question:

is it possible to change cv number for only one spline??

it seems that when i rebuild, all the curves changes their cv numbers.

 

i think i should create a new guide and create singles hair there....

Message 6 of 6
felgryn
in reply to: matteo_bacci

Did this issue get fixed? I seem to be having the same issue with Maya 2000. Trying to use density brush and instead of interpolating from current description, it pastes a bunch of blocks - making the density brush inoperable. Have tried suggestions on this thread and others. Seems i can go back to a simple sphere and make density brush work - but for some reason in my interactive groom - there is some odd bug or magical setting i can't find that causes the density brush to just paste blocks. Any suggestions?

 

felgryn_0-1619672056530.png

And if it's any help in trouble shooting - i note that the place tool does the same thing. Places a single block. When u turn on "Interpolate From Current Description" - it then places nothing.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report