Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XGen hair not showing in viewport or Arnold, increasing hair density crashes Maya

2 REPLIES 2
Reply
Message 1 of 3
tomislav.bosnic1
955 Views, 2 Replies

XGen hair not showing in viewport or Arnold, increasing hair density crashes Maya

I'm trying to create a beard for my character on a piece of scalp geometry I've made - UVs are fine, the object's history is deleted, and the project is set. When I place my guides, clicking the hair preview button does nothing, and hair doesn't show up no matter how many guides are placed. Camera distance doesn't affect it, and attempting to increase density crashes Maya as soon as I go past a value of 5-7. The hair doesn't show up in Arnold either.

 

I've tried creating a new sphere in the same scene for testing, and it's the same deal on it as well. No hair showing up, crash occurs after increasing density. I thought it must be some scene setting as opening a completely new project and XGen-ing a sphere worked, but then I tried exporting my model with alembic, importing it in a completely new project and grooming it there, but it had the exact same issue. Really not sure what's going on here.

 

What is more,  I had done a test groom on this model in the very same scene before and it worked just fine - I've made sure there's no traces of that left so there isn't any conflict with the new description/collection I'm creating. Since I've done that, the model and it's rig/controllers remained unchanged, but I added a bunch more animations, lighting changes, bifrost/aero effects, MASH geometries... a lot of stuff that also underwent plenty of troubleshooting which can only leave me guessing at which of the billion changes could've caused XGen to now be dysfunctional when it was previously working.

 

Any help would be appreciated.

2 REPLIES 2
Message 2 of 3

UPDATE: I've since discovered that the cause of the crash is enabling ambient occlusion in the viewport. After disabling it, I can set the density to any value I want without crashing.

 

However, the hair is still missing - I'm having a very tough time fixing this one.

Message 3 of 3

Hello, did you find the solution? My viewport xgen not working too

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report