Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

XGen export patch for rendering sub frames

5 REPLIES 5
Reply
Message 1 of 6
Anonymous
421 Views, 5 Replies

XGen export patch for rendering sub frames

Is there a way we can export XGen patch for rendering with sub frames? The option in the export window is very limited. 

 

Thanks,

5 REPLIES 5
Message 2 of 6
sean.heasley
in reply to: Anonymous

Hi @Anonymous and welcome to the community!

 

You could try setting the "Render by frame" in Render Globals to some decimal less than 1.000. For example use 0.100. this will render once every 0.100 frames starting with the "start frame". The frames will not be numbered every 0.100 frames however. They will be the usual testFrame.001, testframe.002 etc.

 

I know this works for a normal render and I believe it should work with xgen as well!

 

Please let me know if this helps or if you need any more assistance!

 

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

 

Kudos are greatly appreciated. Everyone likes a thumbs up!

Message 3 of 6
Anonymous
in reply to: sean.heasley

Hi, thank you for your response. When we render sub frames, we'd export alembic sub frame cache first. If xgen export patch for render doesn't generate sub frame in its .abc file, the fur/hair would be offset from render geo, it would result in undesirable motion blur. My question is specific on how to export patch sub frame for render, to give us alembic files with sub frames, not how to render sub frames. If you can get us the answer would be great help.

 

Many thanks, 

Message 4 of 6
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Ah ok I see where I misunderstood.

 

I know you export for rendering fine however I'm not sure about the sub frames. I'm checking with some of our devs to see if this functionality is possible or not and I'll get back to you when I have an update!

Message 5 of 6
Anonymous
in reply to: sean.heasley

Hi, 

 

Is there an update for this? Our production is waiting for the solution. 

 

Thanks,

Message 6 of 6
antonanimator8
in reply to: Anonymous

hi did this get resolved?

im also looking to see if i can solve a simular issue. xgen fur creating bald patches when an animal shakes for example.

 

thanks

Anton

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report