Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

xGen - Deleted Material From Hypershade

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
Anonymous
1002 Views, 4 Replies

xGen - Deleted Material From Hypershade

I just started learning how to use xGen to create fur, so I applied xGen "Groom" type to an object, everything was fine so far.

 

Then I accidentally deleted the xGen material in the Hypershade and a default material was applied to my xGen fur automatically, and now for obvious reasons it doesn't show up while rendering using Mental Ray.

 

So what I did was create another object, apply xGen Groom to it so another xGen material was gonna appear in the Hypershade, it worked, I applied that new xGen material to my fur and it still doesn't render, any idea on how to fix?

 

_________________________________________________________________

 

TL;DR

 

I deleted the main xGen Material from the Hypershade and now my object's fur doesn't show up in the render, how do I fix this?

4 REPLIES 4
Message 2 of 5
Anonymous
in reply to: Anonymous

bump.

How do I apply an xGen material to my xGen fur?
Message 3 of 5
J450NP13
in reply to: Anonymous

Select your fur then in the hypershader right click on the material you want it to have and mouse over assign shader to selected.

Message 4 of 5
Anonymous
in reply to: J450NP13

Would you keep helping me out?

 

I found the trouble, I made a new scene and applied xGen to a new object, compared it with my other object on a different scene, and found out I don't have "xgmr:geoshader" on the scene I have trouble on (picture below of the thing I don't have), to make sure that was the problem I deleted it and I couldn't render the new object's fur, so basically how do I get the "xgmr:geoshader" back into my main scene file?

 

 

Message 5 of 5
Anonymous
in reply to: Anonymous

Solved

 

In case anyone had the same problem and need the "xgmr:geoshader" back you need to

 

- Open xGen editor

- Go to Preview / Output tab

- Search for "mental ray Settings" sub-tab

- Click on "Setup" button

 

That's it, it generates another geoshader

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report