Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Xgen - Candidate guides have not been associated! Fix?

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
PietroLB
9376 Views, 7 Replies

Xgen - Candidate guides have not been associated! Fix?

Hey guys, 

for some reason my xgen tend to lose their guides and display this type of error. I constantly set my project, so that isn't the issue for sure! Is there a way to re-link my guides or find them without having to redo all over again. (Done it already 3 times). 

Thank you very much!

Tags (2)
7 REPLIES 7
Message 2 of 8
sean.heasley
in reply to: PietroLB

Hi @PietroLB 

 

Have you been deleting history on your model? If so that can cause the guides to become disassociated with the mesh they were originally created on. This thread had the same issue and was solved while this thread talks about ways to avoid this in the future and some slight workarounds.

 

I recommend reading through both threads but here's the solution text from the first thread:

 

There will only be a points file if you actually create them. You set At Specific Locations as the generator method then use the point brush to place the hairs. For a head of hair like the one in your grab, Random across surface would be preferable. The clump modifier generates it's own points file (xuv) either from the guide locations, specified points (or both) and randomly generated based on the input settings.

 

The Description folder contains all the files that the description needs that are generated in the grooming process. An xdsc file is only created when you export a description. The XGen file,  which contains all the descriptions in a collection, is saved with the Maya file it is associated with in the scenes folder. The collection file can be exported to a given location as a separate XGen file that can be imported back into Maya if needed.

 

XGen Files and Folders

 

the Guide issuse you ran into shouldn't happen again so long as the points file is on disc, if you used the specific point location generator. Another option for such a specific placement would be to use guides and set the generator to "At Guide Locations" 

 

 

If one or more of these posts helped answer your question, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

 

Kudos are greatly appreciated. Everyone likes a thumbs up!

 

 

Message 3 of 8
jbrophy12
in reply to: sean.heasley

Maybe I'm an idiot, but I'm not following this "solution". (btw- I'm using Maya 2018)

 

Basic problem:
For some reason xgen "forgets" where the guides have been placed when opening a file in which everything was working fine at the time the file was saved.

 

And, no, I haven't deleted history.

 

My workaround up to this point has been to save lots and lots of files as I work on my project. That way the odds are better for finding a recent one that still works and having the least amount of work to redo.

 

But this sucks!

 

What I have done:

I've tried to follow the instructions from previous postings on this topic, but have run into a few problems:

 

1. One of the previous proposed solutions was to use the "Specify Points Tool" from the "Specify Locations" option to "see" them on disc. 

Q. Where is this mystical and magical "Specify Locations" option? The internets tell me that it is in Primitives tab>Generator Attributes, but I don't see it there or anywhere. Maybe it's staying out late with its unicorn buddies. In any case, it sounds awesome!

 

2. I have successfully exported the Collection and Descriptions from an earlier functioning saved scene (the .xgen and .xdsc files), but the only way I've found to re-import them into a more recent non-functioning saved scene is to delete the entire existing (non-functioning) collection from the Outliner first. But once that is done, I get a warning when importing the saved .xdsc files (importing the .xgen Collection fails) saying that a Collection with the same name already exists and do I want to import it as "collection name 1 " and then "collection name 2", "... 3", etc. It then makes a copy of the Collection that is already there and imports that instead.


Q. So if I use that method each time Xgen forgets where it placed its guides I will end up with multiple copies of the Collection of which only the most recent actually works. Is this really the only workflow?

3. I see that under the Preview/Output tab> Output Settings> Operation there are some options for exporting an .xpd file as well as "Create Point File". I've successfully exported a Point File, but...

 

Q1. How do I now import the Point File (*.xuv)?
Q2. Is there a special place in the xgen directory where this Point File needs to live in order to be auto loaded when opening the scene?


PS I apologize for the snark. It's not directed at anyone personally. But it keeps me from tearing my hair out (pun intended).

 

Many thanks.

Message 4 of 8
jbrophy12
in reply to: jbrophy12

Okay, I think I've got this figured out.

For all of you who are getting the "Candidate guides have not been associated" error AND who have not deleted history, this sometimes works. It's not 100%, but it's saved me from redoing work a few times.

Go to File>Set Project and be sure you are pointing to the project with the correct Xgen cache associated with your file. Sometimes it forgets. Once set, try updating the preview again. Sometimes this is all it takes.

Also, I've noticed when opening a file that was saved with the Xgen description out of the camera's range of view (say, you're working on eyebrows, but you were doing some touch up on the hands and you saved the file with only the hands visible) Xgen will not draw the guides and sometimes has trouble accessing them again for the preview. So always save your files with the Xgen descriptions fully visible in the working window. Weird, but there you go.

Now, to keep the dreaded "Candidate guides have not been associated" error from popping up in the first place. It's important to add the "Groom Bake" modifier to the top of each of your descriptions' Modifier stack and save out .XPDs for each of your descriptions. This will create a "scalp name".xpd file inside each of the folders of your descriptions. Once that is done, Xgen should be able to load everything just fine. Ever since doing that I haven't had a problem.

Just get into the habit of adding the "Groom Bake" at the top of each description whenever you get something you want to save. It almost seems like this should be an automatic function in Xgen, but there must be some magical reason why it isn't.

Hope this helps!

Message 5 of 8

Good alternative:

Convert all your xgen to polygons. Take the same time to render and you avoid using this horrendous plugin wich will give you problem after problem.

Message 6 of 8
s.wall2894
in reply to: jbrophy12

Thank you so much 'Jbrophy12', encountered this issue and was stumped as how to avoid it moving forward, but yeah your methods have worked a charm 🙂 

Message 7 of 8
t_smith5
in reply to: PietroLB

I'm having problems with this. I don't get how you can manually add points. I've checked 'More Primitives at' and clicked on Specify Points, but apart from choosing a folder to output to, I'm still none the wiser how to add these points. And nothing shows up in the save folder.

 

As great as XGen is for making hair, the tool is incredibly convoluted, buggy, and difficult to get a grasp on, even with the documentation out there. 😞

Message 8 of 8
shafirahman8699
in reply to: jbrophy12

after applying the modifier if i add any new guides and edit the maps it dosen't seem to do anything. is there any solution for it?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report