Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Which version of libtiff library does maya2022 use on Linux?

8 REPLIES 8
Reply
Message 1 of 9
ttan0037
946 Views, 8 Replies

Which version of libtiff library does maya2022 use on Linux?

Hi,

 

I am one of the Maya arch AUR package maintainers.  One of the library dependency of libmayaOpenImageIO.so.2.0.5 is libtiff.so.5.  However, when I execute the command "ldd libmayaOpenImageIO.so.2.0.5", it complaints "./libmayaOpenImageIO.so.2.0.5: /usr/lib/libtiff.so.5: no version information available (required by ./libmayaOpenImageIO.so.2.0.5)".  libtiff 4.3.0 was installed on my machine and it provides libtiff.so.5.  So, what's the problem?

 

Tianchen

Tags (2)
8 REPLIES 8
Message 2 of 9
Nicolaas.tanghe
in reply to: ttan0037

i got it running a while ago but had 2 reinstall becouse of dualboot.
now i also get the error.
./maya.bin: /usr/lib/libtiff.so.5: no version information available (required by /usr/autodesk/maya2022/bin/../lib/libmayaOpenImageIO.so.2.0)

 

Message 3 of 9
millermaneo
in reply to: ttan0037

Seeking the same information. Where are the devs when you you need them lol

Message 4 of 9

Well only Redhat 8.2 ect. are supported.
So they don`t really have any responsibility to help us out.

I`m just happy it runs on Linux in the first place.

Message 5 of 9

did you get past the issues with segfault that was happening as well the lib tiff issue? 

Message 6 of 9
Nicolaas.tanghe
in reply to: ttan0037

I have Not yet transitioned to using redhat.

A person on the arch aur did post this and I`m pretty sure it will whould fix it on all distro`s.

"

I solved the libtiff.so.5 problem by compiling it by myself but I still have the segfault problem.

If you want to solve the libtiff issue before it got solved by Arch, you can just go download the last libtiff release on the official website, and compiling it with the symbol flag: ./configure --enable-ld-version-script make make install

Also by default it install it under /usr/local/lib*, so you have to create a link to /usr/lib/
" ~cuissedemouche https://aur.archlinux.org/packages/maya/

 

Message 7 of 9
ttan0037
in reply to: ttan0037

I've created a bug report for libtiff package, please upvote to get it fixed ASAP, link: https://bugs.archlinux.org/task/71330?project=1&string=libtiff.  Currently, you will need to manually edit the PKGBUILD file with --enable-ld-version-script option to fix the issue.

Message 8 of 9
Nicolaas.tanghe
in reply to: ttan0037

Can`t seem to register on that part of the forum i dont get a mail with conformation.
when i try to login with my normal aur i dont get anything.

Message 9 of 9
jesinroyD2A3A
in reply to: ttan0037

Hello

Was anyone able to figure out what was causing the segfaults?

It works perfectly fine in windows but the same file just crashes the moment I open it on linux.

Any pointers would be really useful.

Thank you.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report