Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

[WARNING] Unsupported transform node with multiple shape nodes - This scene cont

3 REPLIES 3
Reply
Message 1 of 4
tikka.sharma
2050 Views, 3 Replies

[WARNING] Unsupported transform node with multiple shape nodes - This scene cont

I don't know how to overcome this error which occurs as I try to Export All in Maya as an FBX file:

[WARNING] Unsupported transform node with multiple shape nodes - This scene contains at least one transform node with multiple shape nodes. The plug-in will export only one of the shape nodes.

 

The original file was STEP format which I imported into Maya, added some animation, and am now trying to export into FBX format for Unity development.

3 REPLIES 3
Message 2 of 4

Hey! I know it's been 2 years, but I'm attempting to do the same thing and came across a solution!

 

Select everything in the file that you want to export

Go to Modify -> Convert -> NURBS to Polygons

 

It might still give you the warning, but when I opened my FBX file, it worked! (HOWEVER, importing this file into Unreal/Unity still has some problems. I'll probably reply again or edit my message once I figure something out).

The problem seems to be that STEP files are NOT meshes, and FBX files are. So by tessellating the objects in the file (i.e., converting the shapes to a mesh), Maya now has something to export to FBX. I'm not sure how this will affect animations, though. 

Message 3 of 4

Bro , i love u.This **** problem has been bugging me for a whole week.
Message 4 of 4
tluo1NAD7Z
in reply to: tikka.sharma

Don't worry I got this. After hours of fiddling, I found out that for me at least, there was an weird "camerashape1" object attached to one of my model pieces. In the Outliner sidebar, find the object it was attached to and deleted it from the object heres how: right click on empty space in Outliner sidebar, on the pop-up menu, there will be two check boxes on the very top that saids "Show DAG Objects Only", and "Shapes", makes sure the "Shapes" box is checked. Then you now have the option to open up individual object pieces(Plus Square box thingy will now appear next to individual objects too, usually only appear when objects are "grouped(control+g on multiple objects to make group)" when "Shapes" box is not checked). Now you just have to open up every piece or find which piece this annoying "cameraShape1" thing(or what ever transform node)" is attached to, select it in object outline and backspace. GGs I know its probably too late but hopefully people will still find this useful XD

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report