Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to properly paint nCloth vertex maps?

13 REPLIES 13
SOLVED
Reply
Message 1 of 14
zamielbrink
906 Views, 13 Replies

Unable to properly paint nCloth vertex maps?

As per the title, I am unable to properly paint nCloth vertex maps, no matter what type of file settings I use.  I am a novice when it comes to Maya so I am not too surprised that I can't figure out what could be going wrong, but I've hit quite the brick wall when it comes to what I'm trying to achieve.  Upon attempting to paint my vertex map, the mesh turns white and I am unable to paint anything.  There are times that I have gotten the mesh to turn black and I was able to paint, but I am under the impression that it is unrelated to the nCloth vertex map I am seeking to paint.

Capture.JPG

This is the result of me attempting to paint the vertex map.

 

For context:  I am attempting to recreate an effect applied in This Tutorial at 0:30, where the instructor simulates a jiggle effect with the nCloth vertex map.  The segments brevity and lack of elaboration has left me empty handed in terms of attempting to recreate the effect, and documentation about painting nCloth vertex maps appears to be non-existent.  I am unable to find much helpful documentation or troubleshooting when it comes to this issue, so any guidance would be greatly appreciated.  Thank you in advance.

13 REPLIES 13
Message 2 of 14
syracoj
in reply to: zamielbrink

I believe the artist from the video may be using the cntrl key to paint away (black). It essentially casts the value of the Paint nCloth Attribute Tool to 0 without having to open the actual tools options and manually change the value. Try that and see if that helps. 

Message 3 of 14

Regarding the "I am under the impression that it is unrelated to the nCloth vertex map I am seeking to paint", have you tried to double-LMB-click the active tool icon?

hamsterHamster_0-1631034471302.png

It usually opens tool's options, where you can see what and how you are painting, and where.

As you model/rig/animate, try seeing other tool's options too.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 4 of 14
zamielbrink
in reply to: syracoj

Thank you for replying! Sadly, pressing cntrl yielded no results.  Even editing every tool setting I could see seemed to provide nothing.   However, one odd thing I noticed is once I left my project running and returned to it later, the viewport seemed to update and grant me the result I'm looking for, but there appears to be some major artifacts around where I'm not currently painting.  Do you thing this could possibly be a hardware issue?

 

zamielbrink_1-1631046061132.png

 

Message 5 of 14

Thank you for your input!  Indeed I have, but editing the tool settings doesn't seem to provide much in the way of results.  One odd thing I noticed was once I left my project running and then returned to it later, my viewport seemed to update and give me something closer to what I'm trying to get.  However there appears to be major artifacts, which leads me to believe I may have a hardware issue.

zamielbrink_0-1631046325464.png

 

Message 6 of 14

That COULD be a hardware issue, as, by default, you should have seen color feedback update, impossible to tell from a mere screenshot. Try saving file, exiting Maya, reopening scene.

Also, to understand why you couldn't paint white (100%) over white (100%), you would read the Help article on nCloth attr map idea. Pressing Ctrl while painting reverses the Value of the "paint", not the painting Operation.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 7 of 14
syracoj
in reply to: zamielbrink

so that file is an FBX file? Could you zip it up and post it here for me to take a look at please?

Also, try turning off Cache Playback to see if this helps with any artifacts. No guarantees this will make any difference. Would like to see the FBX file if we could.

 

turnThisOff.png

Message 8 of 14
zamielbrink
in reply to: syracoj

The file present in the screenshot is an alembic file, but I've tested it on FBX as well and the problem remains the same.  I don't believe the file itself is the issue, as the model present in the screenshots is a model I use for testing purposes.  The actual model I wish to apply the effect to is higher poly, but the same issue persists there as well.  Perhaps I could make a short video showcasing the steps I take and provide that?

Message 9 of 14
syracoj
in reply to: zamielbrink

Sure a workflow video would be great. The zipped up scene file though could tell us if there is additional color sets in the file that could be conflicting. Or as the other forum member said, this COULD be a hardware related issue causing the artifacting but would like to rule other things out first.

Message 10 of 14

Sadly, saving and restarting did not appear to fix the issue (I also set my project and applied the "make paintable" option to the model, both of which didn't fix the issue).  Would it be helpful for me to make a video showcasing all my steps in order to pinpoint what I may be missing?

Message 11 of 14
syracoj
in reply to: zamielbrink

yes, a video showcasing your steps is always helpful.

Message 12 of 14
zamielbrink
in reply to: syracoj

Here is my project file and a video showcasing my steps.  Thank you for providing me with such in depth help, it really means a lot. 

Link to the video.

Message 13 of 14

MakePaintable is for PaintFX, nothing to do cloth.

Your vid proved nothing about impaintability of the mesh, because

1) Smooth: takes two neighboring values and decreases the contrast, in your case (100%+100%)/2 = 100%;

2) Add: 100%+100% = 200%, however, since 100% here is maximum the result is 100%;

3) Scale: 100%*100% = 10000%, however, since 100% here is maximum the result is 100%;

4) Replace: 100% replaced with 100% gives 100%.

Would be hard to expect anything else.

Have you tried to touch the Value slider? Decrease the value to 0.5 and try again all the paint Operations; try Flood button.

Regarding the "noisy texture", unless you had loaded some cloth preset, like, Denim, the noise rather LOOKS like a hardware glitch, and all you do is just redraw the area, which appears like something else, but it isn't. Can't test your scene, as the alembic cache is linked to the folder outside the project, and M2019 I have doesn't supporting relinking alembic.

 


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 14 of 14

Adjusting the slider to 0 did the trick, thank you so much! I apologize for any confusion I may have caused, like I said I'm a total Maya noob.  Once again, thank you for your quick responses and coherent suggestions, I am truly grateful.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators