Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

solidshatter is not working in Maya 2018

15 REPLIES 15
SOLVED
Reply
Message 1 of 16
barisvkabalak
8277 Views, 15 Replies

solidshatter is not working in Maya 2018

// Error: file: C:/Program Files/Autodesk/Maya2018/scripts/others/includeShatterEffectsGlobals.mel line 27: An error occurred while running the Solid Shatter script.  Results may be invalid. If necessary, undo to restore the previous situation. " 
15 REPLIES 15
Message 2 of 16
Anonymous
in reply to: barisvkabalak

Make sure you are using Viewport 2.0 and Parallel Evaluation.

 

Message 3 of 16

Parallel evaluation ? How can I use it?
Message 4 of 16
mspeer
in reply to: barisvkabalak

Hi!

 

Make sure to use a "clean" mesh and delete history of the object you want to use with shatter.

Message 5 of 16
Anonymous
in reply to: mspeer

The shatter module is optimized to work best with all the latest updates installed. Have you installed all the latest updates?

Message 6 of 16

I did it but it wasn't work. I Installed all updates 😕
Message 7 of 16
Anonymous
in reply to: barisvkabalak

Is everything "clean"?

Message 8 of 16

Yess
Message 9 of 16
Anonymous
in reply to: barisvkabalak
Message 10 of 16
mspeer
in reply to: barisvkabalak

Hi!

 

Even with the smallest problems in your mesh the Solid Shatter algorithm does not work.

 

For further help please upload the scene-file (containing at least the object you want to shatter).

Message 11 of 16

Thank you I will look.
Message 12 of 16

I will try thank you
Message 13 of 16
barisvkabalak
in reply to: Anonymous

not working again 😕

Message 14 of 16
barisvkabalak
in reply to: mspeer

not working 😕

Message 15 of 16
barisvkabalak
in reply to: mspeer

hii,

 

now it works. 

 

Select object

 

Edit > Delete By Type > History  then Freeze Transformations. 

Message 16 of 16
arcon76
in reply to: barisvkabalak

Deleting history & freezing xforms did not work in my case, although it does work on a basic primitive. 

I'm pretty sure "Anonymous" user in this thread is a bot as the answers have literally nothing to do with shatter or modeling in general.

This is still working only sometimes 2022.2, and glitching other times. The fact that it crashes sometimes even with simple primitives indicates the script was poorly programmed and its problems are nothing to do with "bad geometry".

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report