Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

selection issue

11 REPLIES 11
Reply
Message 1 of 12
s1238795
969 Views, 11 Replies

selection issue

I'm trying to select something in a scene i'm working on and suddenly i can't select anything in my scene anymore and i get this menu whenever i hold my left mouse button. Please tell me there is a way to convince maya that the mouse should be able to select what i want so i can get on with working on the scene i'm in.selection issue.png

 

Labels (1)
11 REPLIES 11
Message 2 of 12
hamsterHamster
in reply to: s1238795

Happens to me too. After some random clicking, switching between programms, it returns to normal, yet annnnnnnoying.

Do you have multiple keyboard layouts/input locales istalled? I suspect those are messing up the hotkeys.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 3 of 12
s1238795
in reply to: s1238795

No, i only have one set up. i wound up just deleting my preferences folder and after two maya crashes in the process of opening it up, it is now fixed

Message 4 of 12
hamsterHamster
in reply to: s1238795

Fingers crossed. I refresh my userPrefs time after time, yet the batman and robin always return.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 5 of 12
fowlert
in reply to: s1238795

The way that marking menu is set up is to attach it to the LMB press but it is supposed to remove itself on mouse release.  There have been bugs over the years where Maya can miss a mouse release event for various reasons and then the marking menu is incorrectly left attached.  If you find it stuck again then just try pressing and releasing ‘w’ and see if it fixes itself.

Message 6 of 12
fowlert
in reply to: s1238795

What I just replied with is technically incorrect, it is supposed to remove itself on release of the ‘w’ key and not the mouse.

 

Pressing ‘w’ (or q, e, and r keys) runs a hotkey callback to attach a marking menu to the LMB (and switch to the move tool).  At this point the LMB marking menu doesn’t need any other key pressed, meaning it’s not a “w + LMB” thing, it’s just LMB.

Releasing ‘w’ runs a hotkey callback that removes the marking menu it attached in the press callback.

 

So if you somehow manage to skip running the release callback then you are now stuck with this marking menu.  Unfortunately, over the years there have been a bunch of ways that Maya could skip calling the q/w/e/r release callbacks, e.g. w + LMB, then pressing other keys at the same time, then releasing w while other keys are down.  There have been fixes made though so depending on the exact version and OS you’re running it might be easier or hard to hit this.

 

When you get stuck in this situation, hitting and then releasing ‘w’ will make sure the release callback runs and cleans things up.

Message 7 of 12
hamsterHamster
in reply to: s1238795

@fowlertThanks. However, pressing/releasing w wit/out LMB/MMB/RMB, doesn't solve the issue. In fact, while I type this, my Maya is with marking menu active in the background.

It was easy to enter the state by pressing the Windows key with mm active - this is frequent accident to me, as the Windows key is located between Ctrl and Alt. Returning focus to Maya keeps the menu, I can enter Center menus and NESW submenus, but can't exit.

After some poking around for this case, I found that pressing (releasing) Spacebar again does the magic.

 

And here, a bonus track (no Photoshop). No other program can do this:

hamsterHamster_0-1615230816639.png

mm+LMB+Alt+Tab.. Luckily, disappears itself on switching back to Maya.

 

More general question: Can't such a bad OS integration be a cause for Redshift (RenderView>RenderSequence) renders to cancel on pressing Esc, even Maya is running in bg, even minimized? Here, someone reported; I tested myself, the issue is real.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 8 of 12
fowlert
in reply to: s1238795

Select, Move, Rotate, and Scale (and a bunch of other tools) all have a marking menu that they each create/delete.  They use the same name for the menu so the workaround of hitting any one of the keys would fix the problem since they would delete the menu of the same name on release.  That was the menu shown in the original posters image.

 

Sounds like the marking menu's posted with the Hotbox share a similar problem, but if the w key release callback doesn't fix it then I'd have to guess that they have a similar way of hooking up the menu's but they don't use the same name.  I think you're confirming this because you say tapping the spacebar does fix the problem caused by the Hotbox?

 

Message 9 of 12
hamsterHamster
in reply to: s1238795

Ok, got the w-menu now. It is active while the Windows Start Menu is active, but disappear on returning back to Maya. Clicking w does not affect the main Marking Menu.

And, I still can generate w-menu+LMB+Alt+Tab "composites":

hamsterHamster_0-1615234848699.png

 


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 10 of 12
hamsterHamster
in reply to: s1238795

@fowlertbtw, hitting the Esc key cancels also the Arnold Renderer, RenderSequence .. which means, this is render-engine independent, Maya integration bug on Win10, can't say about the other OSs.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 11 of 12
damaggio
in reply to: s1238795

Time to address this Autodesk, it's been happening since pre pandemic, I've been hitting W , E,R for 3 years now to make this pop up window go away when I'm trying to move an object.

Message 12 of 12
kent.matheson
in reply to: s1238795

So, months and no one from maya dev even bothers to reply. I'll tell you the apparent solution to this persistent bug: blender

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report