Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Scene Assemblies and the "prepareRender" Command

1 REPLY 1
Reply
Message 1 of 2
Anonymous
369 Views, 1 Reply

Scene Assemblies and the "prepareRender" Command

I'm working on a project that utilizes scene assemblies.  I would like to use the prepareRender command to set the active representation for all scene assemblies prior to rendering, and then return the active representation to the original state prior to rendering, but I haven't been able to make this properly work.  Here's what I'm currently entering into the Pre Render MEL:

 

prepareRender -e -defaultTraversalSet "DefaultSet" -lbl "render" -sac true

 

I get the following error when I render the current frame:

 

# Warning: No matches found for specified custom entry in the scene assembly render options. #

 

For reference, here's the prepareRender article I've been looking at:

 

http://help.autodesk.com/cloudhelp/2015/CHS/Maya-Tech-Docs/Commands/prepareRender.html#flagsaveAssem...

 

Any help would be greatly appreciated, thank you!

 

Dave

Maya 2015 Extension 1

OS X 10.11.6

1 REPLY 1
Message 2 of 2
カワダチアキ
in reply to: Anonymous

This error is usually output when label name is not available.

 

Does this problem happen only with prepareRender command?

Render with the label "render" works from UI without problem?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report