Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems with Arnold renderer (Keeps refreshing)

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
200381d
2531 Views, 6 Replies

Problems with Arnold renderer (Keeps refreshing)

When I try to use the arnold renderer, it keeps refreshing, so I cant view the full render. I assume it has something to do with the file constantly being editted? But how do I solve this.

 

I tried exporting all my geometry and animation to a clean .ma file, and it works until I reopen the file

Tags (3)
6 REPLIES 6
Message 2 of 7
billybobb1
in reply to: 200381d

Getting the same thing when animating ramp texture parameters.   Not an Arnold issue as the Task Manager indicates Maya super busy even when not rendering or playing animation or doing anything.    Maya acts like its playing back at max. speed even when not playing - only when anim curves are present.  This forces Arnold into a crazy refresh cycle. 

 

When you delete keyframes (so # of keys = 1) this stops.   This is killing me right now with a major project.

   

BC

This is a 2022.1 issue, 2020.4 behaves correctly - Mark this a regression Bug.

Message 3 of 7
billybobb1
in reply to: billybobb1

SOLUTION:

Contacted support - couldn't reproduce - suggested the (pretty much standard) delete prefs solution.   eyeRoll..but...

 

After backing up the prefs folder I opened the original and renamed the userPrefs.mel file (OLDuser...) and it now works as expected.   A couple things to reset but not too bad (shelves etc. all good).

 

Hope this helps.

Message 4 of 7
wineandorange
in reply to: 200381d

In my case, i found that issue was contributed by 2 things existing at the same time, particles  automatical caching  while there is  some keyed object in the scene, either I remove one of these the Arnold stoped its infinite refreshing immidiatly  

Message 5 of 7
dkoutsHR2JE
in reply to: 200381d

Solved:

 

Menu > Modify > Evaluate Nodes > ...  Turn off "nucleuses" and "particles"

 

Or disable all.

 

Turn them back on if you want Maya to evaluated nucleus dynamics again though.

Message 6 of 7
nandooo_
in reply to: dkoutsHR2JE

That didn't work 😕

Message 7 of 7
nandooo_
in reply to: billybobb1

I use 2020.4 and have that issue! Have you found a solution for it? Note: resetting Maya's preferences didn't solve the issue. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums