Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Object 'preMelSwGrp' not found

4 REPLIES 4
Reply
Message 1 of 5
e.p.sergun
6839 Views, 4 Replies

Object 'preMelSwGrp' not found

I apologize for the question that has been raised by different users at least four times, but has not received an answer.

 

We are talking about an error message in Maya 2022 (Indie) with the following content:

Error: RuntimeError: file C:\Program Files\Autodesk\Arnold\maya2022\scripts\mtoa\ui\globals\common.py line 2209: Object 'preMelSwGrp' not found.

 

I first started using Maya at the end of February this year. Until July 1, 2021, I did not encounter such a problem. But now it has appeared and even reinstalling the operating system (Win 10) does not help to eliminate it!!!

 

Yes, because of this, I spent a day reinstalling the licensed operating system and downloading all the latest updates and drivers. Then I re-installed Mudbox, 3ds Max and Maya for indie users. But all this did not make sense, since the problem remained.

 

This time I didn't touch the basic Maya settings at all. I just opened an untouched program, created a cube, opened "Display render settings", selected Maya Hardware 2.0 in the "Render Using" tab and clicked "Render the current frame". That's it! No more settings! After that, the above red message appears.

 

The same thing will happen if you select Maya Software or run Hypershade with Maya Hardware 2.0 or Maya Software. At the same time, Arnold renderer functions correctly!

 

If you disable it in the Plugin Manager "mtoa.mll" and restart the program, then when rendering using Maya Hardware 2.0 or Maya Software, there will be no error message.

 

Of course, I tried to install the latest version of the plugin (MtoA 4.2.3 as of July 4, 2021), but it didn't help.

 

Can someone help me with a problem that I think may become widespread?

Labels (1)
4 REPLIES 4
Message 2 of 5
rlbrown_org
in reply to: e.p.sergun

I am getting the same error "'preMelSwGrp' not found". It started after the recent Maya update. It appears to allow renders to finish, but then gives this error.

Message 3 of 5
jquinteroJXV89
in reply to: e.p.sergun

I am getting the same thing  Object 'preMelSwGrp' not found. Actually, I am getting # Error: RuntimeError: file C:\Program Files\Autodesk\Arnold\maya2023\scripts\mtoa\ui\globals\common.py line 2209: Object 'preMelSwGrp' not found.

 

All I am doing is a simple turntable. Someone, please help.

Message 4 of 5

This has been flooding the script editor here for quite a while also.
Am up to the latest 2023.3 updates.  Hopefully this is a requested fix or update for the near future.

Message 5 of 5

Ok, this sounds like an annoyance, but not a showstopper. It is not related to rendering at all (it's a UI-related error), and renderering still works, right? 

It's logged as MTOA-1529



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report