Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Node that returns highest value of 2 or more inputs

15 REPLIES 15
Reply
Message 1 of 16
cerakecera
429 Views, 15 Replies

Node that returns highest value of 2 or more inputs

Hi im looking for a node which returns the highest value of multiple inputs.
E.g
First inputs value is 10 and second is 0, the output should be 10.
First inputs value 0 and second is 9, output should be 9 etc..

If there isnt a node like this, how would you build a connection to achieve this function?
Switched from max to maya some time ago and still learning the node editor btw 🙂

15 REPLIES 15
Message 2 of 16
hagen.deloss
in reply to: cerakecera

Hi @cerakecera 

 

I'm not too fluent with the node editor myself, but if you aren't seeing something that works in the Math node list in the node editor, it might be that it has to be custom-scripted. Here is the list that I'm seeing in the basic shader nodes list. If you are using Arnold or PBR materials, it might be a lil different. Just curious, but why did you make the shift from 3ds Max over to Maya? 

Screenshot (846).png

 



Hagen Deloss
Community Manager | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


 

Message 3 of 16
cerakecera
in reply to: hagen.deloss

Missing that in my list over here. Is that a plugin maybe?
Originally i wanted to do the task with the pose space deformation tool, but it bugs out everytime i want to use it. Maybe you could help me there instead?
Should a make a new thread or post here?
Switched because of Ziva Vfx and Ragdoll Dynamics plugins.

cerakecera_0-1695545971340.png

 

Message 4 of 16
sepu6
in reply to: cerakecera

I believe those math nodes were introduced in M 2024, they might have been in 2023 but not earlier than that. So it depends on what version of Maya you have. If you need a set of math nodes for an earlier version you can try this

 

https://soup-dev.websitetoolbox.com/post/mayamathnodes-20180801-9809635

 

There might some other libraries as well

Message 5 of 16
cerakecera
in reply to: sepu6

Yes that makes sense, im on Maya 2022. Thank you for clarifying this and the link, sepu6!

_______
Sadly i have to say that im pretty dissapointed by the support above, because this could have been told me a month ago when i opened this thread. Only after a direct message to him i got a response without any solution to this simple question. The other question regarding pose space deformation tool was also ignored...

Sorry but having difficulties to comprehend this, wasted a whole month waiting.

 
Message 6 of 16
hagen.deloss
in reply to: cerakecera

Hi @cerakecera ,

 

Sorry to disappoint, although I'm a community manager, not technical support. If you want product support, you can open a support ticket here. I haven't done 3d animation in a while, but with more clarity, I can try to assist! The forums are a place where the community can chime in to help answer questions, the Autodesk support team is mostly dedicated to customer calls and web cases created from the previous link above. If you have further questions about what support entitlements you have with your license; that can be found here

Regarding your use of the pose space deformation tool, what specifically is the issue when you use it? More details would help folks seeing this thread isolate the issue. 

  • Are you currently using the plugins  Ziva Vfx and Ragdoll Dynamics, or did you switch to Maya's built-in solutions after trying to use them? 
  • Have you checked the Maya 2022 documentation around the tool? 
  • Any further clarity around the actual issue, is it displaying strangely, or is the deformer interacting with your rig incorrectly? 
  • Lastly, have you imported this rig/character/asset from another software or version of Maya?

Hope we can help resolve the challenges you are facing 😄 

 



Hagen Deloss
Community Manager | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


 

Message 7 of 16
nobody_b
in reply to: cerakecera

if you dont have the max node from i think 2024, you can use the condition node or the floatLogic and floatCondition nodes to compare numbers

Message 8 of 16
cerakecera
in reply to: hagen.deloss

Not going to argue now about support behaviour etc., instead hoping to finally get this issue solved...
As mentioned above about whether I should open a new thread regarding the pose space deformer issue or post it here, i'll just post it here for now.

The example is a default scene with just the 2 joints and the cylinder. After adding interpolator and first pose it does that deformation. No idea why, since i followed tutorial and docs walkthrough.
This is Maya 2022.3 incl Ziva and Ragdoll plugins.

 

Message 9 of 16
cerakecera
in reply to: nobody_b

Thanks will try those, if i still cant get this psd issue solved

Message 10 of 16
hagen.deloss
in reply to: cerakecera

@cerakecera 

 

Tested this on 2024 and 2022.5 without seeing that behavior, I would recommend testing the following to see if this issue persists.

  • Update your 2022 version of Maya to 2022.5, this might be an issue that was resolved in either .4 or .5.
  • I would also recommend uninstalling/unloading those plugins and testing with a "vanilla" version of the software to rule out plugins being the culprit. 

here is a gif of my 2024 test, and the steps i took to test this issue. 

  • drop down on far left to Rigging view
  • go to Skeleton > create bones
  • select bones first, then mesh.
  • Skin > bind skin
Then i keyframed on frame 1 and frame 20
  • Windows > animation editor > Pose Editor
  • selected the bones and created a pose
  • went to frame 20 and selected "create new pose"
  • Did not see any mesh snapping or other behavior

In the meantime, i have asked the dev team if this issue looks familar to them, and on the offhand chance they request it, would be able to send me a file-sharing link to this test scene via DM? Thanks!

test08.gif 

 



Hagen Deloss
Community Manager | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


 

Message 11 of 16
cerakecera
in reply to: hagen.deloss

Deinstalled previous version and now running a clean maya 2023.3. No plugins, only preferences.
Below a record from start to finish of the issue still persisting and the save of it.

 

Message 12 of 16
hagen.deloss
in reply to: cerakecera

@cerakecera 

 

Thanks for testing that out, now that we have ruled out the plugins, I would for sure recommend updating your 2022.3 to either update .4 or even better .5. You can get those updates from your Autodesk Account Portal. I would also recommend resetting your preferences just in case!

 

Any other thoughts @sepu6@nobody_b , i haven't seen an issue like this with such a simple bone setup before.

 



Hagen Deloss
Community Manager | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


 

Message 13 of 16
cerakecera
in reply to: hagen.deloss

It is 2023.3

cerakecera_0-1696017670457.png

Edit: Resetting preferences didnt change anything

Message 14 of 16
hagen.deloss
in reply to: cerakecera

@cerakecera sorry I read the version wrong!

 

Just to check, is this with completely fresh preferences as well? Would you be able to share the file?

I have no idea why this issue is persisting, and have messaged some colleagues in technical support, I hope they can provide some additional insight. paging @alec.andersenLP8AU and @kelly_hynes 

 



Hagen Deloss
Community Manager | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


 

Message 15 of 16
cerakecera
in reply to: hagen.deloss

Yes fresh prefs.
Last thing i can do here is test the tool on another machine....
Thanks so far for the help

Message 16 of 16

Hi @cerakecera@hagen.deloss 

 

Just took a quick look at this, it looks like the 0.ma file you sent over is bound twice, which is why adjusting the arm by 90 degrees causes the skin folds in on itself. It's actually being influenced twice, so that 90 degree rotation on the joint gets doubled when it's interpreted by the skin. You can see a similar phenomenon occur if you parent one cube to another cube, select both individually, and then translate them. The child cube will race ahead while the parent cube moves linearly.

 

I attached a gif of what I did to your file to return to influence parity (just an unbind). My guess would be that somehow something was selected twice, or bound twice.

 

Hope this helps!

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report