Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No object matches name: internal_standInSE

4 REPLIES 4
Reply
Message 1 of 5
thunderstruck.rock
3176 Views, 4 Replies

No object matches name: internal_standInSE

 

Imagine the scenario - You are doing a lot of shading in a scene.

So, you are working on similar shadings, for example, you need two wood materials with the same textures but the glossiness. You work in the first one and you finish it.

For the second shader, you simply go to the Hypershade menu, Edit> Duplicate> With Connections To Network. The first shader is duplicated maintaining all it's previous connections, and you can change only the glossiness texture of the second, maintaining all the other existing textures for both shaders. Until here, amazing.


The problem is, when you are going to apply the second shader to an object, an error is given:

 

 

// Error: line 1: No object matches name: internal_standInSE //

 

When this happens, your duplicated shader cannot be applied to any object. you have to delete it, create a new shader (not duplicate the first one), relink all the textures and then apply it to the objects you want.

 

Things to note:

1- Not always this will happen. Mainly in complex scenes;

2- I have no clue how a standIn error is related to this;

3- Common duplicate also might give this error;

4- Can happen with any shader, from any plugin;

5- This happens to me since Maya 2016;

6- As this problem might be related to another field than rendering, I decided to post on the general forum...

 

Dou you have any workaround/ reason/ solution to this problem?

Thank you.

 

4 REPLIES 4
Message 2 of 5

Here might be a workaround. I'm not sure which of the two steps was the crucial one but it helped me circumvent the issue:

After duplicating a material (Arnold Standard Surface) in Hypershade, I had the error message when trying to assign the material. 

1) I created a new material which created a new shading group. I used that shading group and connected it to the duplicated material. 

2) I assigned a 3rd material to the object before assigning the duplicated material. The issue might just ocure when yo switch from the original material to the duplicate directly. 

Message 3 of 5

Hello! A little late but this could help anyone in the future, W.rodewald solution's does work but here's an alternative

If you get the error:

1. make sure you apply "Lambert1" to the object in question and try again 
If it still doesn't work:
1. Open the hypershade window

2. Get the output and input of the "Lambert1" shader

3. Break the connection between "Lambert1" and "InitialParticuleSE"

4. Try applying your shader

5. You can plug back the "InitialparticuleSE" Node afterward, but I haven't seen a reason to atm
I'm pretty sure this is a sure fire way of getting rid of the error

Message 4 of 5

Wow, My issue got solved. just started using 2022 and i got this error today. Thank you @thunderstruck.rock 

Message 5 of 5
bitworm
in reply to: lucas.signoles

Thanks to you my friend, I solved the problem smoothly 🙂

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report