Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya Language 2020 Language issue

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
rpark7J3CJN
741 Views, 7 Replies

Maya Language 2020 Language issue

Hello. I accidently turned Maya's language system to Japanese. I tried returning the language back to English while following the forum's instructions. Link will be down below. While I followed the instructions, Maya was still in Japanese. I do not know what to do as I am lost.

 

https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/Maya-Cus...

Labels (1)
7 REPLIES 7
Message 2 of 8
lucericr
in reply to: rpark7J3CJN

How did you 'accidentally' turn it into japanese? 

The MAYA_UI_LANGUAGE environment variable is all that controls it, as far as I know

Message 3 of 8
rpark7J3CJN
in reply to: lucericr

I don't know but my friend left my computer in Japanese Locale to which I changed to US Eng locale. However, Maya was stuck in Japanese.

Message 4 of 8
rpark7J3CJN
in reply to: lucericr

Yeah, I followed the instructions and changed the ENV file but it still remains to be in Japanese.

Message 5 of 8
lucericr
in reply to: rpark7J3CJN

Hello.  Three things.

 

First, if I understood correctly, your buddy changed your Windows PC to Japanese, and you turned it back to English  Maya has no "memory" of the UI language, so if it still thinks that your PC is in Japanese, then you probably did not "fully" turn it back to English.  If you think you have done it correctly, make you reboot the PC for the change to take effect.

 

Secondly, in this last post, you wrote "changed the ENV File".  If you mean you put MAYA_UI_LANGUAGE in "maya.env", the link you posted has warned you that you cannot put it there. The reason is maya.env is read after Maya has already initialized its language.

 

Lastly, a very common mistake when following steps on the web to set environment variables is to copy/paste and end up with an extra space before or after the variable names or values. You can open a command prompt and print the environment variables by typing "set" and make sure that it prints without spaces

 

Message 6 of 8
rpark7J3CJN
in reply to: lucericr

So basically, I write set MAYA_UI_LANGUAGE=en_US; in command prompt and enter right? If this was the correct one, I don't really understand why is my Maya program still in Japanese. Even redoing the command prompt and restarting the PC didn't solve the issue.

 

I also checked other solutions to which led me to this link.

https://knowledge.autodesk.com/support/maya/learn-explore/caas/sfdcarticles/sfdcarticles/Change-Lang...

 

Message 7 of 8
rpark7J3CJN
in reply to: rpark7J3CJN

By the way, I meant that none of the solutions worked. Is it something that I am doing wrong or an issue with the program?

Message 8 of 8
lucericr
in reply to: rpark7J3CJN


So basically, I write set MAYA_UI_LANGUAGE=en_US; in command prompt and enter right?

I'm running out of ideas. I just want to make sure that you wrote =en_US and did not add that ";" at the end that is in that quoted text, because that would not work. It needs to be just:
set MAYA_UI_LANGUAGE=en_US

I've set my Windows 10 local to Japanese, verified that we get Maya in Japanese, and then used MAYA_UI_LANGUAGE to get it back in English, and it works.  If you do it at the command prompt, of course, you will need to launch Maya from the command line in that command prompt so that it gets that variable.


There is something else that might help you. It looks like Maya thinks your system is in the Japanese locale. If that's not what you wanted, and instead you wanted your PC back in English (or your original langage), please follow the instruction here to change your "Current system locale" to English instead of Japanese.  You probably only changed the display language to English and is apparently not what Maya is looking at for setting it language.

  1. From the Start menu, select Control Panel (not "Settings", type Control Panel), and select Region and Language.
  2. From the Region and Language window, click the Administrative tab and select "Change system locale..." button. Change the Current system locale setting to English (United States) or whatever was your original local
  3. Click OK.

    The Windows operating system will indicate it needs to be restarted for the changes to take effect.



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report