Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2023 - F To Frame Components In Isolated View Bug ?

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
davidSFL
1737 Views, 6 Replies

Maya 2023 - F To Frame Components In Isolated View Bug ?

Hi.

Pressing F in the viewport will frame an object or selected component. 
But, i just noticed, when an item is isolated (CTRL+1) the "F" command will only frame the entire object, but not the component that is selected on that object.
I already went through the hotkeys and found nothing unusual. 
Frame Selected is bound to the F key, as it should be and as i said, it will focus on components, but only if the object is not in isolated view.

I'd swear this was different in previous maya versions, but i cant check due to this issue --> Maya 2022 - Installation error - Autodesk Community - Maya

Anyway.
I'd like to know if this is expected behaviour for maya 23 and if so, how can i change it, so it will focus on components also in isolated view ?   

6 REPLIES 6
Message 2 of 7
DaikonGG
in reply to: davidSFL

Yes, I have the same problem. You are right: in Maya 2022 it works as intended (I've checked since I did not delete my previous version). Settings in 2022 are all the same as in 2023.

For now I am using "Frame selection in All Views" (Shift+F), which works properly, but it's no good.

Pretty sure it is a bug of the new version, hope it will be fixed ASAP, since I'm using F hotkey a lot and I need my other views to remain untouched. Please, notify me if you'll find any workarounds or when it will be fixed. 

Message 3 of 7
brentmc
in reply to: davidSFL

Hi,

 

This is a known issue in Maya 2023.

It can be worked around by patching fitPanel.mel that is installed with Maya but this is not recommended unless you are comfortable modifying your Maya installation. (be sure to backup the original file etc before modifying it etc) 

 

In fitPanel.mel replace this line:

if( `modelEditor -q -isFiltered $panel` && ($fitType == "-all" || numSelectedObjects() == 0))

with this one:

if( `modelEditor -q -isFiltered $panel` && ($fitType == "-all" || size(`ls -sl -ufe`) == 0))

 

Brent McPherson
Principle Engineer
Message 4 of 7
kiril.nikolov
in reply to: brentmc

Hi,
Where can i find fitPanel.mel? I'm not seeing it anywhere in maya's files under Documents, am I looking at the wrong place?
Message 5 of 7
davidSFL
in reply to: kiril.nikolov

fitPanel.mel is located inside the following path:
C:\Program Files\Autodesk\Maya2023\scripts\others
Message 6 of 7
kiril.nikolov
in reply to: davidSFL

Thank you! I can finally work in peace now, this bug has been driving me insane
Message 7 of 7
wilven.taveras
in reply to: davidSFL

I know I am a bit late but I noticed this too. I was hoping there was a quick fix, such as a setting selection that would fix this but for those who can't alter much because it is not their machines, you can also click Shift + F and it will zoom into exact component. Also in the Viewport under View you can click Look at Selection (Viewport > View > Look at Selection) or (Shift + F)

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report