Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2022 scenes in Maya 2020 (OpenColorIO error)

19 REPLIES 19
SOLVED
Reply
Message 1 of 20
akcharly
6368 Views, 19 Replies

Maya 2022 scenes in Maya 2020 (OpenColorIO error)

Hi, dear developers.

Can you help to fix this issue?

When I open the scenes which I saved in 2022 in 2020 - I saw this error.

Screenshot_50.jpg
And the scene looks like this
Screenshot_51.jpg
And in Maya 2022 it looks like this 😃 

Screenshot_52.jpg

How to come back to a normal view in Maya 2020? 😃

Thank you and have a great day
Best regards,
Andrew.



EESignature

Відповідь корисна? Клікніть на "ВПОДОБАЙКУ" повідомленню! | Do you find the posts helpful? "LIKE" these posts!

На ваше запитання відповіли? Натисніть кнопку 'ПРИЙНЯТИ РІШЕННЯ' | Have your question been answered successfully? Click 'ACCEPT SOLUTION' button.

Андрiй Кривуля | Andrew Krivulya | 3D Grooming Artist - Facebook | Instagram | Twitter | LinkedIN | Youtube | Artstation



Labels (1)
19 REPLIES 19
Message 2 of 20
Grahame_Fuller
in reply to: akcharly

Hi,

 

This happens because the default color management system in Maya 2022 is based on OCIO v2. Color management in Maya 2020 uses SynColor, which supports OCIO v1 but not v2 config files.

 

There are several ways to fix it. Assuming that you want to work with the default color management in Maya 2020, then:

  1. Open the scene in Maya 2020.
  2. In the color management preferences, turn off Use OCIO Configuration.
  3. Reapply the file input rules (see Change existing input color spaces automatically by reapplying rules) and/or manually specify the input spaces for existing texture files (see Specify the color space for textures and other image inputs). To get exactly the same look as before, you may also need to adjust any colors or lights defined in the scene, because Maya 2020 and Maya 2022 use different tone maps for viewing.

Alternatively, you can:

  1. Start Maya 2022 with the MAYA_COLOR_MANAGEMENT_SYNCOLOR environment variable set to 1. This must be set in your system or in the shell before starting Maya.
  2. Open the scene.
  3. As above, turn off Use OCIO Configuration in the color management preferences.
  4. As above, reapply the file input rules and/or manually specify the input spaces, and adjust colors and lights.
  5. Save and reopen the scene in Maya 2020.

There are other ways to fix it but they require an OCIO v1 config that you want to use:

  • In Maya 2022, set the OCIO Config Path to the v1 config, then fix the input spaces, colors, and lights, and finally open the scene in Maya 2020.
  • Set the OCIO environment variable to the full path and file name of a v1 config and then launch Maya. This config will be used for all scenes in all versions of Maya.

I hope that helps,

gray


Grahame Fuller
Learning Content Developer
Message 3 of 20
akcharly
in reply to: Grahame_Fuller

Awesome! Thank you for this detailed answer. 😃 

Have a great day
Best regards,
Andrew.

EESignature

Відповідь корисна? Клікніть на "ВПОДОБАЙКУ" повідомленню! | Do you find the posts helpful? "LIKE" these posts!

На ваше запитання відповіли? Натисніть кнопку 'ПРИЙНЯТИ РІШЕННЯ' | Have your question been answered successfully? Click 'ACCEPT SOLUTION' button.

Андрiй Кривуля | Andrew Krivulya | 3D Grooming Artist - Facebook | Instagram | Twitter | LinkedIN | Youtube | Artstation



Message 4 of 20
sputknick
in reply to: akcharly

This problem has cropped up like a monster this past month. I've had to work back and forth between Maya 2022 and Maya 2020 and I get endless OCIO error messages. I frankly could care less which one looks better in terms of colors because I am working on animating dozens of various objects where textures aren't a big deal. I just want this problem to stop. I often share files with people who use 2020 exclusively. What is the best way to shut this down in 2022 so I don't "update (or rather destroy") the 2020 files they are handing me, so I can hand them back working? I frankly can't believe there isn't just some preference in 2022 that I can tick off to have a modicum of sanity and compatibility. Any help here?

 

PS: I've even read somewhere that these problems destroy some rigs, I'm thinking that might be the case with me as well.

Message 5 of 20
sputknick
in reply to: akcharly

Here is my problem with the rigs that might somehow be related. Files created in 2022 now (and suddenly) no longer open properly in 2020. This started happening at the same time as I started seeing this OCIO error, and frankly little could be more disheartening as we used to have dozens of these characters that were working well between us, and they took a long time to set up.

Message 6 of 20
Grahame_Fuller
in reply to: akcharly

Hi,

 

You can get rid of the OCIO error messages by setting the MAYA_COLOR_MANAGEMENT_SYNCOLOR environment variable to 1 as described above. Note that this must be set in your system or in the shell before starting Maya. It won't work if you set it in the Maya.env file, because that gets read and applied after Maya starts. However, this won't solve the problems with your rigs because color management applies only to display and rendering.

 

Are you skinning in Maya 2022 and then opening the scene in 2020? If so, then you need to disable the new component tags in Maya 2022 before doing any skinning:

  1. Open Maya's preferences (Windows >Settings/Preferences > Preferences).
  2. Select the Animation category on the left.
  3. In the Rigging section, turn off "Use component tags for deformation component subsets".

If that doesn't help, then I suggest you post your issue in a new thread to get better visibility on the forum.

 

Cheers,

gray

 

 


Grahame Fuller
Learning Content Developer
Message 7 of 20
sputknick
in reply to: akcharly

Thanks Gray for your speedy response. While I consider myself to be computer savvy, I have been lost both times when you suggest the following "start Maya 2022 with the MAYA_COLOR_MANAGEMENT_SYNCOLOR environment variable set to 1. This must be set in your system or in the shell before starting Maya."

 

Is there a link for the uninitiated on this procedure? I don't know how to set maya variables in the system or shell. I don't even know where to look to begin.

Message 8 of 20
sputknick
in reply to: akcharly

Also, I just tried your advice on the rigging problem. It is a no go. Here's my process. I create characters in Character Creator 3 which I then need to animate and refine (add displacement, SSS, Arnold, etc) in Maya. If I import the fbx from CC3 into Maya 2022 and do the refining there, everything is good until I open that file in Maya 2020 where the rig breaks apart. So, following your advice, I turned off the rigging setting in Maya 2022 and I ran this process again today (imported from the fbx), which again works fine in 2022, but the maya file doesn't work in 2020 where the rig still breaks apart. And again, perhaps the most confounding is that this process was working fine a few months ago. I had no OCIO problems and no problems sending files to colleagues with all my rigging done in 2022. It is only recently that it has become a hair pulling nightmare. Still looking to understand how to fix my OCIO issues as I don't have the knowledge yet to adjust the shell or system as you suggest.

Message 9 of 20
Grahame_Fuller
in reply to: sputknick

Hi,

 

The exact procedure to set environment variables depends on your operating system. For example, to set it in a persistent way on Windows 10, you can do the following:

  1. Click the magnifying glass on the toolbar and start typing "envir... ". One of the top matches should be "Edit the system environment variables".
  2. Click it to open the System Properties.
  3. On the Advanced tab, click Environment Variables. You'll see two lists: the user variables affect anything you run on that machine and the system variables affect all users on that machine -- your choice.
  4. Click the appropriate New button.
  5. Enter the name MAYA_COLOR_MANAGEMENT_SYNCOLOR and the value 1, then OK, OK, OK.

Now start Maya in any way.

 

If you don't want to set it persistently, then you can use a shell (also known as a command prompt or terminal window). This affects only programs launched from the same shell and can be useful if you often need to use different settings. Again, the procedure and syntax depend on your operating system but on Windows 10 you can:

 

  1. Click the magnifying glass and type "cmd". The best match should be "Command Prompt".
  2. Click it.
  3. Enter the command set:
    MAYA_COLOR_MANAGEMENT_SYNCOLOR=1
  4. Navigate to the directory where the Maya executable is installed, for example:
    cd "C:\Program Files\Autodesk\Maya2022\bin"
  5. Launch Maya by entering:
    maya

I hope that helps,

gray


Grahame Fuller
Learning Content Developer
Message 10 of 20
ChiChiChAP
in reply to: Grahame_Fuller

I set MAYA_COLOR_MANAGEMENT_SYNCOLOR  to 1 in System Variables but still get the Missing OpenColorIO config error.

Message 11 of 20
Grahame_Fuller
in reply to: akcharly

Hi ChiChiChAP,

 

It sounds like SynColor is still looking for an OCIO configuration file. Note that SynColor supports only version 1 of OCIO, so if the config file is v2 or missing entirely then you will get that error.

 

Check your Color Management preferences and turn off "Use OCIO Configuration". If you don't see that option, then SynColor mode wasn't properly enabled.

 

I hope that helps.

 

gray


Grahame Fuller
Learning Content Developer
Message 12 of 20

can you pls tell me how to enable syncolor mode properly
Message 13 of 20
Grahame_Fuller
in reply to: akcharly

To enable SynColor for Maya 2022 and later,  you must set the MAYA_COLOR_MANAGEMENT_SYNCOLOR environment variable to 1 in your computer's system preferences, or in your computer's user preferences, or in a command shell before starting Maya from that shell. It does not work if you set the environment variable after starting Maya.

Note that SynColor also works with OCIO v1 so if your scene used OCIO then after opening it you may need to turn off "Use OCIO Configuration" in the Color Management preferences (in Maya's main menu, Windows > Settings/Preferences > Preferences then click Color Management on the left).

 

gray


Grahame Fuller
Learning Content Developer
Message 14 of 20

I did this step MAYA_COLOR_MANAGEMENT_SYNCOLOR environment variable to 1 but Use OCIO Configuration option is greyed out what to do
Message 15 of 20
Grahame_Fuller
in reply to: akcharly

You don't need to do anything more -- you're in SynColor mode.

 

(BTW that option becomes only when you enter a path for an OCIO config file.)

 

gray


Grahame Fuller
Learning Content Developer
Message 16 of 20

can you pls tell me where i can find that file ,I cant find it.

Message 17 of 20
Grahame_Fuller
in reply to: akcharly

You need to supply your own OCIO v1 config file to use with SynColor.

But if you want to use OCIO in Maya 2022 or higher, then you don't need to enable SynColor. Maya's default color management is based on OCIO, and in addition Maya comes with default config files.

 

gray


Grahame Fuller
Learning Content Developer
Message 18 of 20

These are the the current setting of 2020 and 2023 maya side by side .When i open scene maya 2023 in 2020 its showing everyting dark what to do in 2020in 2020left 2020 right 2023left 2020 right 2023in 2023in 2023

Message 19 of 20

Hm, really strange issue. In my case, just turning on this option helped.


Screenshot_375.jpg

 

But in your case, it feels like when you open the scene in Maya 2020, the building's normals are reversed. Have you tried selecting it and doing Invert?

Also, I see that the whole scene is a little darker. Have you tried the options from the approved answer?

Really strange issue.

EESignature

Відповідь корисна? Клікніть на "ВПОДОБАЙКУ" повідомленню! | Do you find the posts helpful? "LIKE" these posts!

На ваше запитання відповіли? Натисніть кнопку 'ПРИЙНЯТИ РІШЕННЯ' | Have your question been answered successfully? Click 'ACCEPT SOLUTION' button.

Андрiй Кривуля | Andrew Krivulya | 3D Grooming Artist - Facebook | Instagram | Twitter | LinkedIN | Youtube | Artstation



Message 20 of 20

Thanks .I will repeat the steps and try again.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report