Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2019 Graph Editor refreshes and shows all curves when deleting keys

11 REPLIES 11
SOLVED
Reply
Message 1 of 12
meike5M7YZ
7255 Views, 11 Replies

Maya 2019 Graph Editor refreshes and shows all curves when deleting keys

I've set Maya 2019 to use Classic Graph Editor (though the modern one behaved the same) and have disabled Auto Load. Whenever I select a controller and click on Translate Z (for example) in the Graph Editor outliner to single out the curve, and delete a key, all other curves come back into view because Maya seems to select the controller again. I then have to click Translate Z again to single it back out. This is really frustrating behavior and I had found a way in Maya 2018 to turn this off, I thought it was Auto Load, but it doesn't seem to have effect anymore. Is this a bug, or do I have another setting not set correctly?

11 REPLIES 11
Message 2 of 12
meike5M7YZ
in reply to: meike5M7YZ

Update: every time I open a new scene I have to close and re-open the Graph Editor, and then it works as intended. Prior to figuring this out I had deleted my preferences, and that didn't fix it. So... bug?

Message 3 of 12
meike5M7YZ
in reply to: meike5M7YZ

Update since I can't edit my original post: Auto Load had nothing to do with it!

Message 4 of 12
mskim
in reply to: meike5M7YZ

I didn't found correctly answer

 

If you click base animation layer?

cancel or disable a base animation layer

and then It will be done

Message 5 of 12
efeemachado
in reply to: meike5M7YZ

Still having this issue, but with me it happens when I select more than one key on the Graph Editor.
Does anyone know a solution?

Message 6 of 12
bblim85
in reply to: efeemachado

Hi, i also encounter this issue, wonder if anyone have a solution?

Message 7 of 12
yashank.singh
in reply to: meike5M7YZ

I was having the same issue. Selecting all animation layers and then working fixed it for me. 

Message 8 of 12

This worked for me! Thanks!

Message 9 of 12
dynuke
in reply to: meike5M7YZ

Click "Options" under the Anim tab (anim layers section on the right).  Then click "Key In Last Active Layer(s)" or one of the other 2 options. Then you can go back to your previous setting if you want. This fixed the bug for me. ss.jpg

Message 10 of 12
ChristopherHale
in reply to: dynuke

This bug is still present and I was able to narrow it down to anytime Graph Editor is auto opened on startup with a workspace it will cause this behavior. I have to close Graph Editor and reopen it or "Reset Current Workspace" for this behavior to go away.

Message 11 of 12
daveblanch
in reply to: meike5M7YZ

thanks @meike5M7YZ - this was driving me nuts!
While it seems to be a bug, reloading the graph editor works.

Since mine is docked with the viewports, in the Graph Editor I hit the Time Editor icon to switch, then the Graph Editor icon to switch back again.
 

Reload_GE.jpg

 
Message 12 of 12

Deleting the Pref folder worked for me. I dont know how long it will last but so far, so good.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report