Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2019 crashes when quit it

2 REPLIES 2
Reply
Message 1 of 3
icapathos
898 Views, 2 Replies

Maya 2019 crashes when quit it

Recently, I got in trouble with Maya 2019.

There is no problem while working with the scenes.

But it crashes when I close Maya 2019.

On Output Window I get lines like below

 

Stack trace:
  OGSDevices-16.dll!OGS::Devices::BufferImp<OGS::Devices::AVertexBuffer>::DisposeResource
  OGSDevices-16.dll!OGS::Devices::VertexBuffer::~VertexBuffer
  OGSDevices-16.dll!OGS::Devices::VertexBuffer::CurrentTimeStamp
  OGSObjects-16.dll!OGS::Objects::ARefCounted::ReleaseRef
  OGSDevices-16.dll!OGS::Devices::IDeviceResource::ReleaseRef
  OGSDevices-16.dll!OGS::Devices::SimpleMesh::~SimpleMesh
  OGSMayaBridge.dll!OGSMayaComponentConverter::usingHWSelection
  OGSObjects-16.dll!OGS::Objects::ARefCounted::ReleaseRef
  OGSDevices-16.dll!OGS::Devices::RenderItem::~RenderItem
  OGSMayaBridge.dll!OGSMayaTransformInfo::operator=
  OGSObjects-16.dll!OGS::Objects::ARefCounted::ReleaseRef
  OGSRender.dll!OGSMayaCompoundNode::removeAllItems
  OGSRender.dll!OGSMayaCompoundNode::~OGSMayaCompoundNode
  OGSRender.dll!OGS::Objects::_ListBase<OGSMayaRenderItem * __ptr64,OGS::Objects::RefCountedLifetime<OGSMayaRenderItem * __ptr64> >::operator[]
  OGSObjects-16.dll!OGS::Objects::ARefCounted::ReleaseRef
  OGSMayaBridge.dll!OGSSingleNodeContainer::~OGSSingleNodeContainer
  OGSMayaBridge.dll!OGSSingleNodeContainer::GetLayerNames
  OGSMayaBridge.dll!OGSNodeContainer::~OGSNodeContainer
  OGSMayaBridge.dll!OGSDagItem::~OGSDagItem
  OGSMayaBridge.dll!OGSMayaUIPainter::setShaderItemOverride
  DataModel.dll!TdrawDbSync::~TdrawDbSync
  DataModel.dll!TdrawDbSyncItemBlindData::operator=
  DependEngine.dll!TdependNode::~TdependNode
  RenderModel.dll!TrenderLightShape::~TrenderLightShape
  SharedUI.dll!TmodelEditor::setupColorMgt
  DataModel.dll!TdagObject::destroyNode
  DataModel.dll!TdagObject::~TdagObject
  DataModel.dll!TmatrixModifiedMsg::constructInPlace
  DataModel.dll!TlightRenderFilter::clearLightPath
  DataModel.dll!TlightRenderFilter::~TlightRenderFilter
  SharedUI.dll!TmodelEditor::setupColorMgt
  DataModel.dll!TsceneRenderFilterDescription::clearLights
  DataModel.dll!TsceneRenderFilterDescription::clearFilter
  DataModel.dll!TsceneRenderFilterDescription::~TsceneRenderFilterDescription
  DataModel.dll!TsoloInfoServerRefreshViewMsg::operator=
  DataModel.dll!T3dView::~T3dView
  SharedUI.dll!TiteratorWrapperFwd<TmultiIndexDependNodeSet::NodesOfTypeConstIteratorDescriptor,TiteratorWrapper<TmultiIndexDependNodeSet::NodesOfTypeConstIteratorDescriptor> >::operator++
  3dGraphics.dll!QmayaGLWidget::clearWidgetList
  maya.exe!TiteratorWrapperFwd<TscenePartitions::ConstIteratorDescriptor,TiteratorWrapper<TscenePartitions::ConstIteratorDescriptor> >::operator++
  maya.exe!<13F333752>

 

What I have to suspect in my scene?

2 REPLIES 2
Message 2 of 3
patrick.schock
in reply to: icapathos

Hello @icapathos,

 

I can't see a clear issue in the stack trace. However, I would recommend these basic steps as first troubleshooting approach:

 

1. Open the scene file, select all nodes and go to Edit > Delete by Type > History. Save the file with a new name.

2. If this does not solve the issues, close Maya and reset the user prefs: How to reset the Maya Preferences to Default.

 

Hope this helps!


Best regards,
Patrick

“https://damassets.autodesk.net/content/dam/autodesk/logos/autodesk-logo-primary-rgb-black-small_forum.png”
Message 3 of 3
michael.dinitz
in reply to: icapathos

Were you able to figure it out?

I'm having a similar problem with Maya 2020.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums