Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2018: Error when trying to open preferences and marking menus icons missing

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
sntgndrs
1979 Views, 3 Replies

Maya 2018: Error when trying to open preferences and marking menus icons missing

So, today I noticed my Maya preferences went bananas, so tried to set them once again when this error appeared:

 

// Error: file: C:/Program Files/Autodesk/Maya2018/scripts/startup/updatePrefWndUI.mel line 125: Invalid object or value: 0

 

Also I noticed that my tool bar and marking menus icons had disappeared, I thought that resetting the prefs would fix the problem, but didn't work at all. I also tried to reinstall maya, but still having the same problem.

 

Here's what that line mentioned in the error says:

124          -sl `optionVar -q EEexprEdTextEditor`
125          textEdOpts;

126

127   prefExprEdTextEditor(1);

 

PD: I have seen that there's a similar problem with older versions of Maya, but the las part of the error is different, I think that might be the key to solve this, but I'm not very familiar with those *.mel files.

 

Thanks!

3 REPLIES 3
Message 2 of 4
sean.heasley
in reply to: sntgndrs

Hi @sntgndrs and welcome to the community!

 

When you uninstalled, did you perform a clean uninstall/reinstall of Maya?

 

If not, please do so as this will completely remove all folders related to Autodesk and Maya and should reset you back to 0 and solve this issue with the problem mel files.

 

Please let me know if that works for you or if the errors keep occurring!

 

 

Message 3 of 4
sntgndrs
in reply to: sean.heasley

Thanks @sean.heasley! Problem solved! I couldn't recover my prefs entirely but still, problem solved!

Message 4 of 4
Anonymous
in reply to: sean.heasley

Deleting preferences is NOT a solution. Proposing to do so as a fix is just unprofessional. As a CG sup I cannot lose my prefs every 2 weeks or so!

 

Other proposed "solution" doesn't work either:

 

setting  -iv "EEexprEdTextEditor" to 1 in userPrefs

 

I've had to struggle with this repeated bug for years now and am getting really tired.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report