Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2018 can't assign new material !

15 REPLIES 15
SOLVED
Reply
Message 1 of 16
kea_smartjung
6122 Views, 15 Replies

Maya 2018 can't assign new material !

Hello , here is my problem

1.) Install Maya 2018 on my x64 Windows 10 computer that never installed any Autodesk software before.

2.) Create a cube

3.) Right click then click on "Assign new material"

4.)Got this error

# Error: file: C:/Program Files/Autodesk/Maya2018/scripts/others/renderCreateBarUI.mel line 166: LookupError: file C:\Program Files\Autodesk\Maya2018\Python\lib\site-packages\maya\app\general\tlfavorites.py line 28: unknown encoding: 874

 

I have really no idea about it,how can file corrupt just after installed a software or I have to config something before? Thank.

 

15 REPLIES 15
Message 2 of 16

Hi @kea_smartjung and welcome to the community!

 

It looks like an issue with your graphics card drivers. Can you please check to see if they are up to date?

Steps to update your drivers can be found here!

 

Also can you please post your pc specs so I can make sure there aren't any compatibility issues?

Steps to find your pc specs can be found here!

 

Let me know if anything changes!

Message 3 of 16
sean.heasley
in reply to: sean.heasley

Hi @kea_smartjung

 

I'm just checking in to see if you need more help with this. Did the suggestion I provided yesterday work for you?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

Message 4 of 16
mspeer
in reply to: kea_smartjung

Hi!

 

1. Try a reset of your preferences.
Rename the folder prefs in folder 2018 to something like prefs_backup, or to reset everything, the folder 2018 to 2018_backup (or even the maya folder to maya_backup). Maya creates new folders (don't copy preferences from previous Maya versions). Detailed at:
https://knowledge.autodesk.com/support/maya/troubleshooting/caas/sfdcarticles/sfdcarticles/Reset-May...

 

2. Please check the user path for non ASCII or whitespace characters.

Message 5 of 16
kea_smartjung
in reply to: mspeer

I already try this method and it doesn't work.

I was installed Maya for the first time and use it for the first time so it is in default already.

Message 6 of 16
mspeer
in reply to: kea_smartjung

Hi!

What is with 2.?

Message 7 of 16

Thank for your kind support.

I have update graphic driver to the most recent version on AMD website and launch Maya but still get the same error.

Here is my system:

Windows 10 x64

i5 750

HIS AMD HD5770 with 1GB GDDR5

May be graphic card is old? I have iMac late 2013 with gt750m which is old too but work fine with Maya or HD5770 is just too old?

If it is really caused by a graphic card ,I can make some investment on GTX1050.

Message 8 of 16
kea_smartjung
in reply to: mspeer

Here is my path

C:\Users\kea_s\Documents\maya\2018\prefs

Message 9 of 16
mspeer
in reply to: kea_smartjung

Hi!

 

That looks fine. If the project path is like this there should be no problem with the path, but the error message indicates a format problem (unicode required).

Do you have some other software installed that uses/installed python.

Also make sure no virus scanner blocks files needed by Maya.

 

One thing that you could try (at last step) would be uninstall and re-install Maya.

Message 10 of 16
sean.heasley
in reply to: mspeer

Hi @kea_smartjung

 

 

Also your graphics card isn't on our certified hardware list so it is possible that Maya may be struggling with it but like @mspeer said it looks like a format problem. Did you get a chance to try the suggestions he provided? Did they help solve your issue?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

Message 11 of 16
kea_smartjung
in reply to: mspeer

No other software that use python and I have just Windows defender for virus protection and reinstalling won't solved.

Maybe because I use Thai edition of Windows 10 or my graphic card is too old.

Anyway I use Maya on my iMac now and it work fine.

Thank you for your help.

 

Message 12 of 16
116taw
in reply to: kea_smartjung

Im also having this problem with Maya 2019.. did anyone fix this

 

Message 13 of 16
116taw
in reply to: 116taw

Im now using Maya 2019 still the same

Deleted Prefs folder.. still the same

Updated graphics card drivers

still the same

Graphics card Geforce 1050Ti

Any help

Any Support?????

Message 14 of 16
116taw
in reply to: 116taw

Solution found PC location changed from Thailand to English (United States)

Problem fixed

Hyper shade now working

Message 15 of 16
rachit
in reply to: kea_smartjung

There are possibly 3 solutions -

 

Apart from having a material issue, i am assuming you can't use hypershade window and assign HDRIs to the skydome as well. There will be plenty more .gui realted issues all of which can be solved using the following-

 

1. Resetting Maya prefences

2. Updating the GPU driver compatibility with Maya

3. Using a genuine software instead of cracked or student's version

 

If this doesn't help try resetting your OS, deleting registry files and do a clean "genuine" install of Autodesk products

 

Thank You

Message 16 of 16
henrikeev
in reply to: mspeer

Tkss

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report