Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya 2017 Various Bugs Getting REALLY ANNOYING!

12 REPLIES 12
Reply
Message 1 of 13
Anonymous
4498 Views, 12 Replies

Maya 2017 Various Bugs Getting REALLY ANNOYING!

Hi,

From today I started to use Maya 2017 from 2016 at work, and have hit wall after wall of it doing silly things that never used to be issues before!

First thing I noticed was a graphical glitch when using 'Depth Peeling' transparency sorting in Viewport 2.0: DX11. Orbiting a semi-transparent mesh (transparency on material only, not textures), random polygons on the mesh would disappear and flicker back on as I rotated further. Looking around, this is probably a GPU driver issue, so I'll get that updated soon and let you know if it keeps doing it.

  • Channel box keeps forgetting what size it is.
  • HumanIK window keeps forcing itself to be the default display at startup unless I remove it from the right bar. Not an issue, but just irritating to me.
  • Multi-cut tool just will not work properly for me sometimes, and I can't see why. It will work just as it did in 2016, and then suddenly stop snapping to edges/verts for me to cleanly slice faces up. Instead, it keeps only drawing over the screen as if I'm holding Shift with nothing highlighted. It seems to start working again most of the time if I test it on a poly-plain mesh, and not work on my actual model. I would think maybe I've done something wrong on the model making it confused, but if I bring my model back into 2016 it works just fine again.
  • UV editor seems to be responsible for crashing Maya with 'Fatal Errors' repeatedly, often using the new layout tool.
  • Undo is broken and amazingly irritating to use now. It appears to be 'undoing' what should be internal commands looking in the script editor, instead of just what the user has last done. This results is having to spam Ctrl+z 3-4 times just to undo an incorrect slice of a polygon face. I see this is currently in the works for a fix already though, right?

Hopefully the first update will address most of what any of these issues are in one way or another. I'm finding myself having to trouble-shoot weird issues more than actually work today -.-

12 REPLIES 12
Message 2 of 13
Anonymous
in reply to: Anonymous

Maya 2017 isn't great. It's the most buggy version I've used so far.
Message 3 of 13
Anonymous
in reply to: Anonymous

Undo has been broken forever. And it is never going to be fixed. Been using Maya since 2005 and always marveled at the "no more undos" message when there were clearly more. But rejoice -  undo crashes are less common never minding core functionality. 

Tags (1)
Message 4 of 13
andreasng____
in reply to: Anonymous

the undo is broken. I'm used to Maya 2012 which was a breeze compared to 17.
Message 5 of 13
andreasng____
in reply to: Anonymous

I thought it was fine in 2012..... "fine" that is.
I'm in 2017 now, and the undo is messed up. Slow. Takes a couple of undos to undo 1 thing.
Message 6 of 13
Michael_Todd
in reply to: Anonymous

That sounds like a prefernce setting that needs to be changed:

 

Undo.png

 

You need to either change the queue length of turn it to infinite...

 

cheers



Michael Todd

XGen Product Owner and Designer

Message 7 of 13
Anonymous
in reply to: Michael_Todd

Yeah - thanks and no thanks. Of course I am aware of that setting and this has nothing to do with the issue at hand. Maya's undo/redo implementation, if we want to call it that, is hit or miss and extremely crash prone as is well known. But for the instances where it works it will still screw up in a majority of instances. One test that I have supplied to you guys numerous times is to do a parity test several hundred actions into modeling with an infinite undo chain. Do a bunch of undos, reds, undos and you should see the famous no more undos warning in red pretty soon. If Maya survives of course.

Message 8 of 13
stevetoons
in reply to: Anonymous

Maya is also having problems undoing when you move keys on the timeline, with or without "Consolidate Undo steps for Time Changes" checked. Also sliding keys on the timeline is hit or miss. Fps preferences don't stick anymore, even from saved files. My whole team is experiencing an absurd amount of bugs. This is one of the buggiest versions of Maya I've used. 

Message 9 of 13
stevetoons
in reply to: stevetoons

Also cannot select camera from the hotbox menu anymore. 

Message 10 of 13
Michael_Todd
in reply to: stevetoons

Again, sounds like a prefs isssue because it's working fine for me with clean prefs:

 

CamSelect.png

 

It could also be a video card drivers issue



Michael Todd

XGen Product Owner and Designer

Message 11 of 13
Anonymous
in reply to: Michael_Todd

dont think the undo is a direct problem - I find the undo drops off if I've had a crash from another source.

 

I found using legacy viewport and setting animation evaluation mode to DG solved several of my problems

Message 12 of 13
Anonymous
in reply to: Anonymous

I have recently installed maya 2017.Its getting frozen without internet connection.And when i plug in the internet cable and restart it again..it starts working normally.How can i get rid of this problem.Does maya 2017 work only if there is internet in the system.Kindly suggest.

Message 13 of 13
Anonymous
in reply to: Anonymous

In 2016, you may already know, that having the Hypershade window open will cause the Undo Queue to become longer than what you would expect.

If you close the Hypershade, then one action can be undone with one undo.

 

Please consider this a bug report.

Hypershade window open consumes undos.

 

Maybe it has been fixed in 2017. I don't know. Sometime I just don't care. Sorry.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report